Bimmerfest BMW banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So....
Last week I was driving on the motorway doing around 70 :rofl: when the DTC started kicking in and limiting power to the wheels.. (it was wet at the time) and I assumed that there was no problem and that I should slow down.. so I did and the problem went away however the car did the same the next day (still wet at the time) so I slowed down again. so 2 days go by and nothing happens, then when starting the car one morning almost immediately after pulling away off my drive I got a tyre low pressure warning light so I pulled over and checked all my tyres and none were flat... so I did what all self appointed BMW mechanics do and went on a Forum and found that the Reluctor rings were either gone or the sensor was broken... after looking on Real OEM for the part number I noticed that my car doesn't have reluctor rings !! It however has a wheel speed sensor (DTC pulse generator) on all 4 corners instead so I ordered 2 off ebay... I know... Shame on me... Should have Known...

Anyway so 4 days go by and to avoid the computer from randomly braking my wheels I switched off DTC while commuting.. then the sensors arrive so over the weekend in my spare time I replace the two rear dtc sensors (reading this back to myself one of the front sensors may be bad) and all goes well until I started the car..... MY GOD.....

3 Lights instantly showed up the (!) light, ABS and the DTC warning light so a day goes by and I need to use my car and I only drive 10 miles or so and the next morning I go out expecting the same thing....

5 LIGHTS ON THE DASH.. now the Airbag light and Restraint system light have joined the party and I'm playing BINGO with my dash lights..... I go to drive the car to see if anything clears up I make it 3 miles down the road to a friends and the SPEEDOMETER STOPS WORKING!!!!!! AHHHHHH.... so I park the car on her drive and turn off the car (by this point I'm pulling my hair out...) and the steering lock malfunction light comes on :mad: so I restart the car and then turn it off again and it sorts the steering lock out..... :bawling:

So.. what I'm asking is can I have a second opinion to the problems I'm having is it definitely the wheel speed sensors? Should I now fork out the money and replace all 4 (I am going to put the Two original rear sensors back on the car tonight and get all the error codes cleared (I know a qualified mechanic with the tool) and see what corners are throwing the errors) and hopefully there wasn't an issue with the rear sensors and maybe there is a problem with one of the front sensors?..

Thank you for any help..
It will be Gratefully accepted..
-KeNNy
 

·
Registered
Joined
·
97 Posts
Hard to say. But I think it is a good idea to go back to the origin conditions of your problems (installing the original sensors).
If it kills most of your warning lights, you'll know the new sensors were creating more problems then they solve.

I did had DTC turning on on the highway years ago... I had a blow out tire. Felt nothing in the steering wheel. Walking around the car, looking at the tires trying to see what was wrong... It took a long time to figure it out (run flat tires - tire didn't collapse when flat). The blow out tire was having a cut about 4 - 6 in long!

Just for the fun of it, (I guess you already did) check the tires pressure... who knows
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3 (Edited)
UPDATE:
So I didn't really have time over Christmas to resolve the issue however one weekend I did replace the original OEM wheel speed sensors on both rear corners and after about a 5 min drive the Restraint, Air bag and ABS lights all switched off and the speedometer started working again.. :thumbup: So those speed sensors got sent back to the dodgy Ebay seller :rofl:.
so now the car was back to a drive-able state and I left it to the next day and magically all lights cleared up... :eek: so the issue (unsolved) had gone..

One week later I had to drive to London around 80 miles and thought it would give the car a good run and if there were any issues they would most likely arise..
half way there BINGO. the flat tyre and DTC started playing up again.. so enough is enough. I took it to a local garage and asked only for a code scan to see which corner the car thought had a flat tyre.. got the usual oh this is is worn you need your tracking done would you like a service? NO! I'M FINE!
what was the error code? Don't know i just cleared it... :mad: eventually he said something along the lines of the car had slow punctures in both front tyres and that they needed resealing .... so i don't think that's quite the problem but we will see.. I will update if anything else comes up if the flat tyre error code shows up again, will take the car back to the garage to get the exact code however (Touch-Wood) 3 days no lights :)

Very strange ......
-KeNNy
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hard to say. But I think it is a good idea to go back to the origin conditions of your problems (installing the original sensors).
If it kills most of your warning lights, you'll know the new sensors were creating more problems then they solve.

I did had DTC turning on on the highway years ago... I had a blow out tire. Felt nothing in the steering wheel. Walking around the car, looking at the tires trying to see what was wrong... It took a long time to figure it out (run flat tires - tire didn't collapse when flat). The blow out tire was having a cut about 4 - 6 in long!

Just for the fun of it, (I guess you already did) check the tires pressure... who knows
I Have run-flats will triple check pressures tomorrow!
 
1 - 4 of 4 Posts
Top