BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
So I recently did some work on my beamer (n52 engine). I had to fix an oil leak and replace the crankshaft position sensor. As many of you know that sensor is a S.O.B and you must remove a lot of stuff to get to it. So along the way replaced any gasket that I came across and a couple of hoses, had some difficulties with some hoses so I just broke them and replaced them. The oil leak turned out to be the oil filter housing gasket so I replaced both on there no problem. Initially I was getting a no crank no start on the car. I had to replace the battery since charging it wouldn't work and my lights both interior and exterior kept flickering. I also banged on the starter with a hammer and after that it started up but was very rough to start and the rpm would move up and down for about 2 mins then go away. I then replaced the MAF sensor (very expensive) and have no more problems. I am now only getting these 2 error codes P0102 and P1415. The car starts fine and runs fine I test drove it around for about 50 miles and nothing. It did feel a little shaky when I went over 60mph. Anyone have any idea what this could be? I have gone through the car to see if anything is loose but everything is right were its suppose to be. Could it be the wiring to the MAF sensor? Or possibly a vacuum leak?

P0102 = Mass Air Flow circuit low output
P1415 = ???
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Think I may have found the culprit. The hose next to the throttle has a broken tab? Could this be the problem. It feels secure even with 1 broken tab. Now the question is how to remove the other side that is attached to the wire harness box thingy. Anyone know how?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
So if anyone having same issues I managed to change that hose it's the fuel tank breather valve and it cleared up the P1415 code now I just have the P0102. Though both cleared briefly after installing the hose but P0102 came back
 
1 - 5 of 5 Posts
Top