BimmerFest BMW Forum banner

2007 BMW 335i E90 Sedan Automatic - Jumpy Car, 02 Sensor Codes and Few Electrical Pr

2112 Views 3 Replies 2 Participants Last post by  diefromrock
Car just hit 120,00 miles…

Current Problems with the car:

1. Car rev limits drops sporadically and gets jumpy.

2. Windshield Wipers do not work.
Replaced Relay, and wipers still do not work
Checked every fuse and every fuse is good. Went ahead and replaced any old looking ones.

3. Windows randomly will not want to roll up. Lately just having a problem with my rear driver window. The rest of them seem to work fine now.

4. Passenger heated seat not working. Also the light on the heated seat switch for the passenger seat does not come on at all. Driver side is fine. I replaced all fuses related to heated seats and replaced with a new center console switch for heated seats with the same problem continuing to happen.

5. Few days ago Check Engine Light came on and the car stalled while driving down the interstate. It now like to stall more often. Went by Advance Auto yesterday and got them to read the codes and they pulled up p0420 and p0430.

6. I just replaced the battery yesterday, still no changes, the one in the car previously was a lower cranking rating then what is recommended and also had low reading and still had lower reading after I left it on the charger. I thought maybe a weak battery might could have caused some of these things. But apparently I was completely wrong and now at least I have a nice new battery lol.


So after reading a bunch of forums, websites and repair manuals it is looking like it could be a variety of things. I’ve seen ideas such as follows…

1. Camshaft Position Sensor, description of this sounds like what is happening to my car with the rpm jumps and stalling. But why am I getting codes P0420 and P0430 now….

2. Now that I have those codes could it be 02 sensors(however would these cause the car to have rpm drops and car stall).

3. Catalytic convertor.. Since both 02 Codes popping up…

**** Side Note, This car pass emissions in Atlanta a month ago… ****

4. Crankshaft Position Sensor

5. Lamda Sensor

6. Vanos Solonoid Valve

7. DME


**Current Display lights - Check Engine - Air bag - Seat Belt **

*** Current warnings - Left and Right Headlights, Rear Lights, Brakes, pretty much every light lol, but they all work fine. Have HID’s in front. ***



Planning to do:

Already plan on ordering Spark plugs and Coils to replace. Getting new Air and Cabin Filters(Burger Tuning), also plan on getting the JB4 tune if get things worked out with the car.

Will order whatever sensor might need.

Thinking of getting rid of cat with a pipe since don’t have emissions for another 2 years if cat is causing the problems.

Going to follow lines for electrical issues to make sure everything is getting power.

Lastly going to take the DME out and inspect it for any burns or inperfections.

I do have cable and downloading software to read/write codes, cable may come in mail late tonight or tomorrow. I realize getting codes checked at advance auto is not always the most reliable and only does so much…


So after all this, does anyone else have any other suggestion or similar problems that have had success fixing your car?





Honestly I haven’t had much time to look at the car and pull things out due to working a bunch lately and bunch of trips having to go on. Had Sons Birthday this past weekend, going back down for his party this weekend, then Disney World for Thanksgiving, so hoping can get a day or two and bunch of nights in to work on car lol. One can hope.


Lastly, to add to this short story, while I am examining these things and replacing anything do you guys have any other recommendation I should do? Thinking about looking into replacing hoses and rubber belts like suggested in inspection 2. Jus need to look all those parts up.
1 - 4 of 4 Posts
:thumbdwn:

Also think about feeding back your exhaust pipe into the cabin and take some deep breath.
Thinking of getting rid of cat with a pipe since don't have emissions for another 2 years if cat is causing the problems.
"
1. Camshaft Position Sensor, description of this sounds like what is happening to my car with the rpm jumps and stalling. But why am I getting codes P0420 and P0430 now….
"

Camshaft would cause limp mode / reduced power but the engine wouldn't stall.

"
2. Now that I have those codes could it be 02 sensors(however would these cause the car to have rpm drops and car stall).
"

Your codes are about catalytic converter efficiency that is calculated by comparing the precat sensors to the postcat sensors.
If the post cat sensors are failing, that would not cause engine running problems.
Precat sensor failing would throw other codes and the car would go to into open loop control reduced power.
Maybe precat sensors but unlikely


"
3. Catalytic convertor.. Since both 02 Codes popping up…
"

Do you have excessive mileage? like 250k+ miles?
Or did the car run for a longer period with misfire codes?

Converters are either get clogged, reducing engine power permanently or getting saturated or burned through and popping P0420, P0430 codes.

"
4. Crankshaft Position Sensor
"

this can cause engine stalling

"
5. Lamda Sensor
"

lambda sensor == O2 sensors

"
6. Vanos Solonoid Valve
"

this wouldn't cause stalling and would give camshaft position error codes

"
7. DME
"
maybe but unlikely




Also you seem to have some electrical problems with the BUS system. I would fix that first, clean up everything
Spark Plugs and Coils made the ride smooth again. After I changed plugs and coils, I went ahead and changed crankshaft and cam positioning sensors. Took a trip to Florida and ended up getting a pin needle hole in cooling hose, got the car towed home and went ahead and did a complete cooling re-hall( Water Pump, Thermostat, All Hoses), changed pulleys and accessory belt, Got VRSF down pipes with downpipes code fix( Acoste I know you are proud :) ), BMS DCI, JB4, and ER charge pipe with Tail bov. No more codes and got everything set up perfect. Smooth ride and world of a difference with the upgrades.

Also got a free windshield wiper motor and that solved wipers. Passenger seat still not heating, imagine something to do with the map wiring in seat. Rear passenger window getting stuck most likely due to a little bit of tint at bottom peeling up(need to re-tint obviously :/).

The random idling/stalling was just coils/sparks though. Easy and quick fix.
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top