BimmerFest BMW Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My car suddenly slow down on the freeway and gave me the message of Transmission Malfunction. In pulled over and all of my warning lights were on, so I turned the engine off and tried to re-start the car but everything starting dying as if the battery was going dead. I couldn't even take the key out anymore. I called AAA and with a power buster they were able to give some power to get the key out, however the car also started but the AAA guy said it was probably the alternator or the battery so the car was towed home. Since the car started I drove the car the next few days around the house and it worked fine. But after sitting without use for 3 days the car was completely dead (no electrical power). I jump-started the car however the shift-lever would not come out of park and once I turned the car off everything die again.

Does anyone know what could be the issue? Battery or Transmission? or something else!

I have considered to just replace the battery but I read that the computer system needs to be reset every time a new battery is installed. Is that true for my model? Even Autozone and O'Reilly have a warning on their batteries

Please Help!
 

·
Registered
Joined
·
4,884 Posts
Thanks, do you know if that is what made the other warning lights to act up?
This car is very sensitive to battery level. Low level can be caused by old battery; failing alternator; failure to "go to sleep" properly when shut down; IBS cable.

Check the battery -- older than 4 years, just replace it.
Test the alternator.

After that, if there's still failure, come back and we can go to the next step.

Power management description attached. But the #1 problem is usually an old battery.

There are good cheap replacements at Autozone, etc. Search this forum for "battery".
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks Banglenot for the reply, I changed the battery and the car starts with no problem however the shift lever does not moved from the park position and all of the warning lights are still on. I was able to turn it on a couple of times and take it out of the park position however in a couple of seconds it changes back to the park position. I had it towed to a BMW shop today and by closing time they couldn't still figure out what the problem is. I don't think the shop specializes in BMWs. All they could tell me is that it is an electrical problem and something didn't re-set it self when I changed the battery. They claimed they re-set the system a couple times but it comes back to the same issue every time. They are keeping the car for now.

Is there something else I should look for? Thanks
 

·
Registered
Joined
·
118 Posts
Thanks Banglenot for the reply, I changed the battery and the car starts with no problem however the shift lever does not moved from the park position and all of the warning lights are still on. I was able to turn it on a couple of times and take it out of the park position however in a couple of seconds it changes back to the park position. I had it towed to a BMW shop today and by closing time they couldn't still figure out what the problem is. I don't think the shop specializes in BMWs. All they could tell me is that it is an electrical problem and something didn't re-set it self when I changed the battery. They claimed they re-set the system a couple times but it comes back to the same issue every time. They are keeping the car for now.

Is there something else I should look for? Thanks
There was a video with similar issue like yours let me find it and I will get back to you.
 

·
Registered User
2008 535xi wagon
Joined
·
3,227 Posts
Sounds like a transmission solenoid to me. But that may be a result of low power. 2008+ uses a solenoid to engage park.


There may be a sticking relay or something that is causing the car to stay awake when it should be shutting down, draining power . It takes about ten minutes after you turn everything off for everything to actually power down, but if something is keeping it in its "hey, someone's doong something still dont shut down yet" mode, your battery will continue to drain.

Battery should be the same chemistry as before (agm or fla. Shake it, if it sloshes its fla) and battery adaptations should ideally be reset or the new battery will be charged as if it was an old one, reducing overall life. It's literally a button for someone with a scan tool. Hell, for the 50 bucks it costs to get someone else to do it you can get a scan tool and inpa from eBay and do it yourself... And then you'll have a scan tool.
 

·
Registered
Joined
·
118 Posts
Thanks Banglenot for the reply, I changed the battery and the car starts with no problem however the shift lever does not moved from the park position and all of the warning lights are still on. I was able to turn it on a couple of times and take it out of the park position however in a couple of seconds it changes back to the park position. I had it towed to a BMW shop today and by closing time they couldn't still figure out what the problem is. I don't think the shop specializes in BMWs. All they could tell me is that it is an electrical problem and something didn't re-set it self when I changed the battery. They claimed they re-set the system a couple times but it comes back to the same issue every time. They are keeping the car for now.

Is there something else I should look for? Thanks
Here you go
http://youtu.be/v9mvs3gEDtc
 

·
Registered
Joined
·
118 Posts
Thanks Banglenot for the reply, I changed the battery and the car starts with no problem however the shift lever does not moved from the park position and all of the warning lights are still on. I was able to turn it on a couple of times and take it out of the park position however in a couple of seconds it changes back to the park position. I had it towed to a BMW shop today and by closing time they couldn't still figure out what the problem is. I don't think the shop specializes in BMWs. All they could tell me is that it is an electrical problem and something didn't re-set it self when I changed the battery. They claimed they re-set the system a couple times but it comes back to the same issue every time. They are keeping the car for now.

Is there something else I should look for? Thanks
Also I forgot to tell you guys
I changed my battery last week and dealership told me they charged me $90 to reprogram the battery or update I don't remember exactly . So maybe get ur battery programed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
The mechanic re-programed the battery, they did a re-set on everything, clear all the codes and the car starts and all the warning lights are going however in a matter of seconds it goes back to park suddenly and all of the warning lights return. I am having the car tow to a BMW only shop tomorrow and I'll mention all the suggestion on the forum and see what happens. The other shop claimed they tried a lot of things but could not figure it out. I was not there maybe they just don't know BMWs.
 

·
Registered
Joined
·
118 Posts
The mechanic re-programed the battery, they did a re-set on everything, clear all the codes and the car starts and all the warning lights are going however in a matter of seconds it goes back to park suddenly and all of the warning lights return. I am having the car tow to a BMW only shop tomorrow and I'll mention all the suggestion on the forum and see what happens. The other shop claimed they tried a lot of things but could not figure it out. I was not there maybe they just don't know BMWs.
Check out the vid I linked same problem as u and gives u a solution what needs to be done
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top