BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Lost my keys and after sitting up for 3 weeks I replaced the battery and got a new key programmed..now...STEERING WHEEL CLUSTER BUTTONS DONT WORK AND MY WINDSHIELD WIPERS WONT CUT OFF NOR DO MY TURN SIGNALS WORK..HELP ‼‼‼
 

·
Super Moderator
Joined
·
2,071 Posts
Not that it should affect what's going on here but was the battery registered?
Also do you have the BMW software like ISTA?
Disconnect the battery negative terminal and check fuses 17 (5 amp) and 28 (20 amp) in the glove box.
The fuses above are for the steering column switch cluster, if they are fine then it may have an error or got itself stuck due to no power for a while (all sorts of weird things can happen with the electronics on these cars when they don't get power for a few weeks), run the codes and see what comes back, there may be other modules in the link that have a problem but this is the one that springs to my mind from what you say isn't working.
 

·
Super Moderator
Joined
·
8,869 Posts
The battery will need to be registered soon, but it should not be causing your problems. If it is low on voltage from sitting on the shelf, it can cause these problems & other lights on the dash. Try charging the battery overnight tot see if this helps.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I just took the 30amp fuse out of location 16 to cut the windshield wipers off but in the meantime the brake lights , turn signal and steering wheel nor the horn works🤷🏽‍♂️
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Not that it should affect what's going on here but was the battery registered?
Also do you have the BMW software like ISTA?
Disconnect the battery negative terminal and check fuses 17 (5 amp) and 28 (20 amp) in the glove box.
The fuses above are for the steering column switch cluster, if they are fine then it may have an error or got itself stuck due to no power for a while (all sorts of weird things can happen with the electronics on these cars when they don't get power for a few weeks), run the codes and see what comes back, there may be other modules in the link that have a problem but this is the one that springs to my mind from what you say isn't working.
Didn't work..I just took the 30amp fuse out of location 16 to cut the windshield wipers off but in the meantime the brake lights , turn signal and steering wheel nor the horn works🤷🏽‍♂️
 

·
Super Moderator
Joined
·
8,869 Posts
This is starting to sound like the SZL module, that controls all of these components. The steering wheel needs to be removed to access it. All of the wiper, horn, cruise control, & heated steering wheel go thru this module. There are fuses in the glove box, & one I think in the trunk. Strange that this would happen, just changing a battery?

I think you need to find someone with ISTA or a high end diagnostic tool to read what codes you might have? Somethings going on, & this is about the only way you will figure it out?
 
1 - 6 of 6 Posts
Top