BimmerFest BMW Forum banner

2008 - My first trip to dealer for service

857 2
Bought my car(2008 328xi coupe) ‘certified pre owned’ about 6 months ago. I love it!!
Just recently brought my car in for service. Had shaky idle, washer fluid leaking, rear window defogger not working and jack pad block missing. Got a chrystler 200 loaner.
Also added an alignment, fuel injector cleaned, coolant flush, power steering flush, Nitro for tires.
They said I needed a battery and that the washer was ok. I asked them to check again because we saw the fluid leaking from the wheel well. So they checked again and sure enough the washer motor had a hairline crack. (motor covered under warranty)
Got the car back, the next day there was ice on the window so tried the window defogger. Still not working. Brought the car back. Got a Nissan Altima loaner.

They fixed the defroster (fuse junction box) and while driving home car got shaky again and the SES light came on. Brought it back again. This time got a BMW loaner! That was nice.
They finally found the issue, bad coil in cylinder number 4. (covered under warranty)

Hooray, it’s finally all fixed up!! It took a few trips, but they finally took care of everything. (I hope!)
1 - 3 of 3 Posts
Good to hear hehe.. Good luck with it!

Which dealership?
Thanks!
Was Habberstad - Bay Shore. Was all fixed in the end so I'm satisfied.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top