BimmerFest BMW Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey everyone,

I have a 2008 X3 with 62,000 miles I just picked up.

I'm now getting the Airbag (SRS), 4x4 warning light, and yellow brake warning lights, see attached photos.

I checked the cables under both seats and tried to ensure all visible plugs are fully seated. I have the cheapo 1.3.6 china scanner and getting a traction control, ABS, and SRS code. The SRS code won't reset using the scanner.

The lights all went off today on the drive to work, now they're back on. Sometimes the the 4x4 and yellow brake light goes off for a while, then finally the SRS light. I charged up the battery last night in case low voltage was the issue, but saw the same issues today, any other ideas?
 

·
Tar Heel Faithful
Joined
·
14,127 Posts
Did you buy the vehicle as a CPO? I would suggest taking it back to the dealer. Usually electronic hiccups like this are due to a dying battery, but your vehicle is relatively new so perhaps the battery is defective.

The DSC and Brake warning light indicate that xDrive and/or DSC has failed and that Dynamic Brake Control has also failed. The SRS light obviously indicates a fault with the restraint system.
 

·
Aficionado
Joined
·
3,016 Posts
Hi,
I remember seeing a thread or two on this some time ago, I want to think that disconnecting and reconnecting the battery cured the problem but I'm not positive, do a search on this forum and invest some time reading through the threads.
If not, that's a fault on the DSC/Xdrive systems and only dealer or a BMW specialized shop can diagnose. How.s the car driving?
 

·
Aficionado
Joined
·
3,016 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
Update on original post

@AzNMpower32 - No CPO here, I didn't want to pay for the warranty.
@X3-terrestrial - car is driving perfect!

Other updates:
I talked to the dealer and he thinks it's the battery. Come to think of it, I was detailing the car the weekend before the warning lights started coming on, perhaps having the doors open and courtesy lights on for 1-2 hours might have drained the battery down to an unstable voltage.

CKautogroup offered to replace the battery for FREE which is awesome, I'll probably take them up on it since, well, why not?

I talked to another professional and he thinks it's the ignition switch. Although, the warning lights have gone off and stayed off for a day now, I'm not sure ignition switches get flaky, then aren't flaky all of a sudden.

The problem has subsided for now and I still want to say it was due to low voltage. Yet, I charged the battery overnight and observed the issue the next day so that cause doesn't entirely explain the issue.

:loco::loco::loco:

Chris
 

·
Registered
Joined
·
321 Posts
......perhaps having the doors open and courtesy lights on for 1-2 hours might have drained the battery down to an unstable voltage.
Chris
You can turn the courtesy lights off with the doors open. Just open all the doors you want open and push the dome light switch. They will stay off until you open a door. If the hatch is open you'll have to wait for the cargo lights to time out which takes about 20 minutes.

You can also play the radio without the key..... Just push the radio power button. It will time out in about 20 minutes so you'll have to keep pushing it to keep it playing longer. The steering wheel controls don't work but all the radio buttons do. If you have the iPod cable in the glove box that works too.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
Now 4x4 light, yellow brake light, SRS light on always, SRS stays on after position 1

Still having the problem, 4x4 light, SRS light, and yellow brake light all come on now always. Any suggestions before I put down $100 for a diagnostic? Dude before this says transfer case actuator but that doesn't explain the SRS light, or the SRS light staying on after I turn the key back to position 1. Mechanic thinks ignition switch, any other ideas? Could the SRS light be connected to the drivetrain in any way? Need help!

Chris
 

·
Registered
Joined
·
2 Posts
MY FRIEND 4x4 light, SRS LIGHT And the brake light all @ the same time on. that will be the TRANSFER CASE. check on that.!! the thing is you don't feel any difference on the driving. But is annoying having all does lights ON.!! Feels like you have a christmas tree on your dashboard GAUGES. GOOD LUCK.

Condeking.
 

·
Registered
Joined
·
3,892 Posts
No, Chris says that the car drives perfectly.

If it was the xfer case, there would be noise and/or drivabilty symptoms.

Even a gremlin in the xDrive electronics will put the system into a restricted/safe mode,
and there is absolutely no reason for the SRS light to be part of the same issue.

So the suggestion of a faulty ignition switch makes a lot of sense.
It explains why the SRS light is involved, why the problem is intermittent but continuing,
and why there is no problem with the drivability.

Might be hard to avoid that diagnostic fee, short of waiting for things to develop further.
But if it has not logged any fault codes, the normal dealer diagnostics might not help.
 

·
Registered
Joined
·
18 Posts
Hi There.

I had the same combination of lights come on and it was the Steering Angle Sensor that needed replacing.

HTH.

Cheers, Ben
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #13 ·
New battery didn't help

I took it into the shop and they listed several things wrong, including a weak battery. I figured try the battery, erase all codes and see what happens. After swapping batteries, and then clearing the codes, the lights did stay off for a quick trip around town. Later in the day however, all 3 were back on again and are on now. At least this shows it wasn't a faulty battery causing the SRS light, yellow brake light, and traction control light to all come on. I'm going to reset the codes one more time and make an appointment with the dealership. Will update once I know more. Chris
 

·
Aficionado
Joined
·
3,016 Posts
Hi There.

I had the same combination of lights come on and it was the Steering Angle Sensor that needed replacing.

HTH.

Cheers, Ben
I've heard that sensor going bad before and causing the same array of lights. I know there are more sensors that work with Xdrive and can go bad including the ABS sensors, also there are yaw and lateral acceleration sensors, and the brakelight switch.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #15 · (Edited)
Problem was the steering angle sensor

Turns out it was the steering angle sensor. After updating the software, installing a new battery and clearing all error codes, the lights came back on within 20 minutes of driving. I'll upload the work order in case anyone is interested, it was about $250 for the part and $400 labor since they were not familiar with the fix. Gotta give thanks to CK auto group who took care of me after the initial purchase. Chris:)
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #16 · (Edited)
Steer Angle Sensor Work Order - Fixed my Issue

Here's the work order for the Steering Angle Sensor. You'll see they had to create additional room to remove the part by going under the vehicle, I'm not sure if this step is needed or if there's a quicker procedure.



I left off the prices but figure around $255 for the part and $320 or so for the labor. Also, part of the procedure is updating and flashing the computer, another $120 or so depending on where you go.

Germany's Best Inc. did this repair for us, they're out of Oakland CA. I would definitely recommend them if you're in the Bay Area, their phone is 510.658.8948.

One more thing, if you have adaptive lights and you think your steering angle sensor might be going, see if the adaptive lighting works when you experience all 3 warning lights on (traction control light, yellow brake light, airbag light). Mine was not working which should have tipped me off that the steering angle sensor might be the issue. Hope this helps and also hope I don't have to come back to this forum too soon. :rofl::rofl:

Chris
 

·
Registered
Joined
·
2 Posts
4X4(yellow) , BRAKE(yellow) , Airbag(red) lights ON at dashboard

It was snow yesterday and all 3 lights came together and not going away. It happened earlier but went off quickly.

I took to dealer for some noise last week and they said that they replaced rockers and lifters and since then I noticed that the overhead passenger airbag yellow light ( not on Dashboard , its overhead) is lit for last 1 week. Now this this 3 lights came off together. Another observation is that after the 3 lights went ON the DTC button is not working.

I'm wondering if this trio lights is due to snow covering the sensors or due to what they were doing with lifters and rockers last week ?

Some folks are saying that its due to "Angle sensors" going bad - is that covered under CPO extended warranty ? I bought the car 8 months back at 48K miles.
 

·
Registered
Joined
·
1 Posts
Yellow brake light and 4x4 lights

after reading all the posts for this problem, and someone here said that the steering angle sensor was bad... I shut the car off, losened the latch that moves the steering wheel, smacked it up and down a couple of times and restarted... Worked like a charm!!!! All lights out. Hope it works for everyone
 

·
Registered
Joined
·
1,291 Posts
after reading all the posts for this problem, and someone here said that the steering angle sensor was bad... I shut the car off, losened the latch that moves the steering wheel, smacked it up and down a couple of times and restarted... Worked like a charm!!!! All lights out. Hope it works for everyone
I think that is exactly how Russian astronauts fixed a serious problem on the International Space Station. :) Hit something with a large pipe wrench - works every time.
 

·
Registered
Joined
·
94 Posts
Three Yellow Lights - my story, so far

I have been searching this forum and can't find a definitive answer, and don't know exactly where to put this post, but I think this is the best thread for it.

1. I have a 2006 X3, and one day while backing and turning at the same time I got this awful experience that felt like the car was applying the brakes itself, and upon straightening out and going forward I got the dreaded three lights: yellow SRS and 4x4, and red ABS lights.

2. I drove it in this condition for a while, and noticed a flickering speedo, which eventually became a speedo that would stop working shortly after starting and driving.

3. Some time before all of this began, I had a squeak, squeak, squeak sound when I rolled slowly, which was never successfully diagnosed.

4. I bought a scanner that can read BMW codes, and got this:
(scanner image attached)

5EB1 Steering-angle sensor, supply

5F3A Transfer case: malfunction

5E35 Wheel-speed sensor, plausibility, rear left

5E30 Wheel-speed sensor, supply, rear left

5. I bought a wheel speed sensor.

6. I also bought a new, plastic gear for the transfer case actuator, since this was implicated from the error code and the research I had done.

7. I had a mechanic-friend swap the gear and replace the left rear wheel speed sensor.

8. Now the light trio was off, but would come back, except all yellow, on occasion. This occasion is often coincident with a hard right turn, as when entering or exiting a highway, on the ramp.

9. When the lights are on I experience, at low speeds while turning, what feels like one rear brake being applied, in one or more pulses.

10. I also experience, when standing still with the brake applied and engine running, as at a stop light, a thumping sensation through the floor of the car. It feels to me, in perhaps due to my vivid, mechanical imagination, like the transfer case motor is running and the worm is bumping off the gear, perhaps stripping, as if there is a limit switch for the actuator motor not functioning.

I have not scanned for error codes since the gear and wheel-speed sensor repair, I will try to do that this weekend, and update this post.

I guess I need to repair or replace the steering angle sensor, unless someone can offer a 'cure,' as in recalibrating or addressing the 'supply' issue mentioned in the error code. Any and all input on this is greatly appreciated!

Thanks,

jv
 

Attachments

1 - 20 of 28 Posts
Top