BimmerFest BMW Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hey guys ,

Been getting some transmissions light about transmission malfunction with Turbine speed sensor short circuit to ground or
open circuit.

What could cause that, if I were to get the transmission oil change etc.. would that help and if so apart from oil what else I will need to get eg. Parts to get that done.

I just want buy the parts before I take it to mechanic.

2009 BMW 750I
 

·
Super Moderator
Joined
·
1,050 Posts
It's unlikely that a trans fluid change would fix this. I had the same error on my 2001, I had to replace either the input or output speed sensor (can't recall which), but in order to do that, you have to drop the pan, so if you're going to have someone drop the pan, they should go ahead and replace fluids and the trans filter (oem only!!) too. It could also be a wiring issue based on the "short to ground or open circuit" error, so they should inspect the wiring as well. Take it to a good shop, or else you'll be going around in circles trying to track this down.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
It's unlikely that a trans fluid change would fix this. I had the same error on my 2001, I had to replace either the input or output speed sensor (can't recall which), but in order to do that, you have to drop the pan, so if you're going to have someone drop the pan, they should go ahead and replace fluids and the trans filter (oem only!!) too. It could also be a wiring issue based on the "short to ground or open circuit" error, so they should inspect the wiring as well. Take it to a good shop, or else you'll be going around in circles trying to track this down.
Thank you for the advice

2009 BMW 750I
 

·
Super Moderator
Joined
·
8,332 Posts
Hey guys ,

Been getting some transmissions light about transmission malfunction with Turbine speed sensor short circuit to ground or
open circuit.

What could cause that, if I were to get the transmission oil change etc.. would that help and if so apart from oil what else I will need to get eg. Parts to get that done.

I just want buy the parts before I take it to mechanic.

2009 BMW 750I
I would run the diagnostics before doing anything, ISTA should show the problem. I would not be ordering any parts without knowing what the problem is 1st.
 

·
whughes
Joined
·
2,026 Posts
changing the fluid, you only get about half of what is there, and you will probably break some sludge loose putting in the new fluid, so after 100 miles or so, change it again. you are only diluting the old fluid, but you do get more of the sludge out
 

·
Registered
Joined
·
9 Posts
.... if I were to get the transmission oil change etc.... would that help ...
No.

.... transmission malfunction with Turbine speed sensor short circuit to ground or open circuit....
This is a sensor failure on the electronic part (TCM) of the mecatronics unit (valve body + TCM), this is usually a high mileage issue. It can be fixed with a replacement TCM, and the only way to get a new one (that I know of) is with a complete mecatronics unit for around $2000. Getting a new valve body is not necessarily wasted money since it should be due for a rebuild anyway.

But there is the option of sending the TCM to Bulgaria to be repaired and sent back to you for around $520 (look on ebay for 6hp28 TCM rebuild service).
 

·
DoingAllright
Joined
·
133 Posts
Either that or rebuild it yourself!
 

·
Registered
Joined
·
5 Posts
my 2011x drive has a slipping issues going into second its getting worse. i wonder if anyone has put the new zf8 speed into these cars and is it a direct swap?

otherwise i think it could just be a solenoid swap required? any suggestions.

the symptom is:
it goes into second softly then disengages then goes back in and if you try to accell more briskly the car stutters
 

·
Registered
Joined
·
5 Posts
Hey BMWF012009, just wanted to see if and how you fixed 400626 turbine speed sensor code. I am getting it as well as code 1D3901 as soon as I get in the car before starting the engine.
 

·
Registered
Joined
·
5 Posts
Hey guys ,

Been getting some transmissions light about transmission malfunction with Turbine speed sensor short circuit to ground or
open circuit.

What could cause that, if I were to get the transmission oil change etc.. would that help and if so apart from oil what else I will need to get eg. Parts to get that done.

I just want buy the parts before I take it to mechanic.

2009 BMW 750I


I know this is an old thread, but did you ever fix this problem
 
1 - 11 of 11 Posts
Top