BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I'm having a problem with the parking brake it shows limited and a lot off my things are not working my dash won't fully work power is limited car won't accelerate as it should it happens off and on I can't figure out what it is does anyone know what this problem may be
 

·
Registered
Joined
·
325 Posts
Any pictures? Possible battery issue, blown fuses, oil issues tranny


Sent from my iPhone using Bimmerfest
 

·
Super Moderator
Joined
·
8,332 Posts
I'm having a problem with the parking brake it shows limited and a lot off my things are not working my dash won't fully work power is limited car won't accelerate as it should it happens off and on I can't figure out what it is does anyone know what this problem may be
I would suspect a bad battery is causing your problems, our cars don't like low voltage. Anything less than 12 volts can cause problems like you are having.
 

·
Registered
Joined
·
12,235 Posts
Do you know how to unlock your cluster and go to the TEST that will show your battery's voltage...if yes, do that and report back what it is. Is the car on its origina battery? If yes, then it is 8-9 years old...which is probably past its "use by" date. :)

If you don't know how to unlock your cluster...just do a youtube search for "unlock BMW instrument cluster"...there are multiple videos for various generations of BMWs...find a video of a BMW cluster like yours being unlocked. BMW models that are generational cousins of yours will have the same procedure (e60/e90/e70/e63/etc).
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I would suspect a bad battery is causing your problems, our cars don't like low voltage. Anything less than 12 volts can cause problems like you are having.


The battery voltage is good 12.5 while car is off took the battery to get checked and charged it just in case to see. When I put the battery back in it did the same thing nothing changed went outside an hour later and it was back to normal I woke up this morning and it came back while I was warming up the car it’s driving me crazy


Sent from my iPhone using Bimmerfest mobile app
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Do you know how to unlock your cluster and go to the TEST that will show your battery's voltage...if yes, do that and report back what it is. Is the car on its origina battery? If yes, then it is 8-9 years old...which is probably past its "use by" date. :)

If you don't know how to unlock your cluster...just do a youtube search for "unlock BMW instrument cluster"...there are multiple videos for various generations of BMWs...find a video of a BMW cluster like yours being unlocked. BMW models that are generational cousins of yours will have the same procedure (e60/e90/e70/e63/etc).


It won’t let me unlock the cluster and I think it’s because of the the dash not fully functional the battery is 4 years old and is showing good voltage 12.5 while in the car windshield wipers won’t turn off while in this mode


Sent from my iPhone using Bimmerfest mobile app
 
1 - 7 of 7 Posts
Top