BimmerFest BMW Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
Brought this beautiful car to independent BMW repair B & N here in Ventura because my rear window washer was somehow leaking. Sprayed into rear on my great dane, LOL! . Hose had a leak, that filled up the stereo /tel compartment, and that cost me over $1.2 to fix/replace. 152k miles. Rear hatch operation at the time was fine....

Ahem. I get car back and notice on open and closing intermittent brief grind/ sound for about a second, both on way up and down on rear hatch. opens and closes, but in between for about one second in the middle on the way down, THE GRIND.
I blame mechanic who worked on the water hose, operation of hatch hadn't done so before. Owner uses a bunch of excuses, I tell him NO PROB BEFORE, your fault now, Fix it!

Any idea what I'm dealing with? In this CV19 time, $$$ are tight, Thru demolition yard I think I can get a reasonable shock/electric motor thing.... Just don't know.
Appreciate any comments:mad: you may have, thx

http://s1.bimmerfest.com/forums/images/smilies/cursin.gif
 

·
Resident Curmudgeon
Joined
·
26,385 Posts
who knows? Mechanic could have damaged operator. $500 each. Used ones will fail sooner than new ones. Sometimes much sooner.

$1200 seems steep for a leaky hose.

You're kinda stuck with the shop... he holds all the cards. If you could get a second opinion as to the current issue and likely cause, that would be good leverage.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top