BimmerFest BMW Forum banner

318i - Wipers intermittently not working - possible causes?

1501 Views 10 Replies 5 Participants Last post by  gline
Hi all,

I have a 93 318i saloon

Problem i am having is - the wipers sometimes dont work at all at random.

So, sometimes i turn them on and they work, then othertimes they dont move at all.

What could be the cause. Am I right in thinking replacing the fuses and the relay owuld be the first thing to try? If this isnt the issue what else could it be? Motors?

Regards
Glen
1 - 11 of 11 Posts
Thanks for the link.
Seems to be a bit of a different issue I am having, that users blades where stopping in middle of a cycle, however mine wont even start the cycle at all sometimes.

So basically if I am driving along sometimes when i try to turn the wipers on, they dont move at all and i can keep trying them and they wont work, but randomly I can try say 10mins later and they will work (without turning off the engine or anything).

I suppose il try the fuses and relay first. then i am out of ideas :p
ooh, but that is the fault with mine, time to check my relay tomorrow
Maybe its the controller on your steering column. Something is probably loose or a connection is bad. :dunno:, just a possibility
yeh i was thinking about that. is that located just at the bottom right of the steering coloum (right hand drive)?
I'm not sure about the right hand drive platdorm, but maybe. Just open up your steering dash and check it out.
yeh i was thinking about that. is that located just at the bottom right of the steering coloum (right hand drive)?
Ever think maybe your window wiper motors are starting to fail??
what you mean?
yeh that will be the last thing to check/replace :D
Ever think maybe your window wiper motors are starting to fail??
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top