BimmerFest BMW Forum banner

1 - 11 of 11 Posts

·
bratmeister
Joined
·
134 Posts
Discussion Starter · #1 ·
My '91 318is developed a problem two days ago. With the ignition off, I noticed that the blower continues to run. I have to switch the blower to the zero position to turn it off. Also, last night while shopping with the wife, we noticed the auxilary cooling fan running as we walked back to the car. I had left the A/C switch in the on position when I parked the car. When I turned the A/C off, the aux fan turned off with it. The ignition switch was off so the fan should not have been running in the first place. Thinking nothing of it, we went shopping at a few other stores, turning the A/C and blower off each time we parked it. It was too hot today to venture out so the car sat all day. This evening when I went to start it, all the dash lights lit up very dimmly and the car would not start. When I jumpered to the post under the hood, I still couldn't start it. A direct jump to the battery solved that issue.

After reviewing my Bentley manual and the BMW ETM CD, I'm thinking the problem is a relay which is probably stuck in the on position. I plan to start swapping relays out of my 325i tomorrow in an effort to track this down. Has anyone else suffered from this problem and successfully troubleshot it? Is there anything else I should be looking for? Ignition switch perhaps? Any ideas would be appreciated.
 

·
Registered
Joined
·
294 Posts
are you sure the ignition is actually in the off position?

i can take the key out in the first 2 positions, the more forward one, is not actually off :)
 

·
On Top
Joined
·
8,772 Posts
AlarmedBread said:
are you sure the ignition is actually in the off position?

i can take the key out in the first 2 positions, the more forward one, is not actually off :)
Your ignition is jacked my friend.

Mike I think your right on track. Sounds like a stuck relay to me. Knowing you I'm sure you tested whether other components had power outside the a\c circuit to eleminate the ignition.
 

·
bratmeister
Joined
·
134 Posts
Discussion Starter · #4 ·
SWISS said:
Mike I think your right on track. Sounds like a stuck relay to me. Knowing you I'm sure you tested whether other components had power outside the a\c circuit to eleminate the ignition.
I think it unstuck itself when I went to swap the unloader (K7) with one from my 325i as I heard it make a metalic click. When I went back and tested the blower it wasn't on anymore. Likewise the aux fan didn't run with the A/C on and the ignition off. It's been behaving since Sunday morning and I haven't had any issues with battery drainage. If it acts up again, I'll get a new one and replace it.

All other accessories plus headlights would go off with the ignition so I doubt the ignition switch is the problem.
 

·
Registered
Joined
·
4 Posts
Where is the Relay for the AUX Fan ? Mine keeps running and wore my battery down I pulled the fuse just keep off till i correct this. Is this also related to my ABS light staying on?
 

·
Registered
Joined
·
4 Posts
SWISS said:
Read th3e e30 DIY I posted a fix for the ABS in our cars.
could not find the post you mentioned so that makes 3 things i can't find. your post, AUX FAn Relay, and ABS light fix. Batting Zero
 

·
Registered
Joined
·
7 Posts
How was this resolved???

Hi, did you come to resolution on this? Was it a realay? If yes, which one? I believe I am having this issue right now. My climate fan and mirror controls stay on after ignition is off. My battery drains. Thanks
 

·
Registered
Joined
·
4 Posts
Not Yet

Prolem has not been resolved. I temp. pulled fuse for fan. which means A/C is at a minimum. Let me Know if any body can help
 
1 - 11 of 11 Posts
Top