BimmerFest BMW Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 1990 318is went to start it one day and no go. I have had the ecu tested its fine, i have replaced the main, fuel pump and o2 relays. Still no go. I can't hear the fuel pump when i turn the ignition on and there is no spark although there is power at the coil. If anyone can help me it would be greatly appreciated.
 

·
another E30 nut
Joined
·
916 Posts
is it turning over? Might be a bad fuel pump or ground.
The ground wires get oil laden and stop grounding.
 

·
Premium Member
Joined
·
11,072 Posts
Spray some starter fluid into the part where the air flows threw......I forget what its called, by spray it in there, the car should start, and if it shuts off again, than its you're fuel pump
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Yeah the car cranks. I thought fuel pump straight away but to lose spark at the same time seemed very strange.
 

·
another E30 nut
Joined
·
916 Posts
yea, sounds like a grounding problem. That is if you replaced all of the relays. If not recheck them.
If the ECU is good there arent many more options to check
 

·
another E30 nut
Joined
·
916 Posts
wait. Power is getting to the coil right? but theres no spark. Have you replaced the coil?
M42s have a coil for every cylinder. So i doubt its those
 

·
another E30 nut
Joined
·
916 Posts
yea, thats the good thing about M42s they wont completely die if its one of the coils. Just miss terribly :)
Im gonna start using the word "earths" in replace of ground. See how many newbies i confuse.
 
1 - 10 of 10 Posts
Top