BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Bimmerfest nation, this is my first post and I need some help, I have a 2000 323cic, had it since new 60,000 miles summer car as I live in the frozen north, anyway the car has been in storage in my garage since October, I start it every 2 weeks, when I started it yesterday there was a bang, and now there appears to be no power steering, the atf reservoir is full, do I need a new ps pump? or does anyone have another idea?
 

·
TheMalibuMafia
Joined
·
12,882 Posts
Hi Bimmerfest nation, this is my first post and I need some help, I have a 2000 323cic, had it since new 60,000 miles summer car as I live in the frozen north, anyway the car has been in storage in my garage since October, I start it every 2 weeks, when I started it yesterday there was a bang, and now there appears to be no power steering, the atf reservoir is full, do I need a new ps pump? or does anyone have another idea?
Did a check engine light go on?. If so get the codes for us and will tell you whats wrong.
 

·
Noone Special
Joined
·
684 Posts
Pop the hood and look to see if the belt is still on the power steering/alternator/water pump. Is the alternator light in the cluster on (the one that looks like a battery). You may of just popped the drive belts.

The bad news if the belt broke it may of damaged other parts. Look at the front of the motor to see if the belts are still on before you worry about other damage.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top