BimmerFest BMW Forum banner

325e squealing belt, coolant drop

794 Views 2 Replies 2 Participants Last post by  morganism
Was having serious idle looping issues with this M20.

Finally figured out it was a coolant bubble at the sensor in the thermostat housing.

This morn, the GF started it and it did that power steering howl you sometimes get at start-up, but it just keeps going. Plenty of nasty fluid in there, and some on the return line also. Have a replacement reservoir to install, but doesn't seem to be coming from the pump.

Am ordering a water pump now, but can't find a belt tensioner for that belt in the parts companies. Tried Rock and Pelican, nothing but a timing belt tensioner.

Is there a one in the loop? Loosend the alt tensioner to stop the squeal, but am still a bit mystified which component is the problem. Fan didn't wobble at all when tension released from said alt tensioner.

PS. Best local part store power steering fluid for a commuter ? El cheapo coolant?

Thanks in advance
1 - 3 of 3 Posts
Usually, tightening the belt will get rid of the squealing. If you have already tightened the belts as far as the adjustment bolts will allow, it's time for new belts. Realoem.com has plenty of good info and diagrams, I suggest taking a look there and in your Bentley manual. P.S. I believe if you take a look at your power steering reservoir cap, it will tell you to use A.T.F. not power steering fluid.
Ok, looks like i am going to go ahead and do the timing belt too.

I cant find a sticky, and my search didnt turn up anything definative.

Will try again tomorrow
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top