BimmerFest BMW Forum banner

1 - 10 of 10 Posts

·
Banned
Joined
·
3,403 Posts
I disagee. It must be an error code. Please refer to the bentley manual. lololol

Just kidding, but really, with the music there you asked for it buddy. :)

Your lcd display or your instrument cluster's circuit board has a defect (probably the latter). It may be some capacitors or a short somewhere. You need to remove it, open it up and take a good Mk2 eyeball check of the board, and then start testing things with tools if you have them.

Please google for more information about this, there are websites that will show you how to open the cluster up. Your problem is a very unusual one...its the first of its kind for us, so do keep us posted about your diagnosis and ultimate repair.
 

·
Lucky to drive a BMW
Joined
·
1,356 Posts
I would venture to guess that your check control module is defective.Its up by the fuses try unplugging and replugging it in. The module is about 5 inches long an 1 1/4 thick black box says "check control" on top. unplugs at base multi pin conn. I have a spare if you need for cheap.:)
 

Attachments

·
Registered
Joined
·
538 Posts
Hey guys,

New to the forum and need some help. I was recommended here by a friend and former bimmer enthusiast. The heads up display in my 90' 525i is on the fritz!! it flashes and displays random numbers symbols and letters. Can anybody tell me a reason for this? Thank you in advance for your time!

http://www.youtube.com/watch?v=0ji28xK06Hc&feature=player_profilepage
Found this info on a thread:
Symptoms of a bad or dirty A/M switch are inconsistent display on instrument panel.

Wouldn't hurt to take it apart and clean it.
 

·
Lucky to drive a BMW
Joined
·
1,356 Posts
No actually after further research there is a rarely seen warning -/?/?--??--// code that comes up when the system detects strange music being played on the sound system system.:wave::fruit::
 
1 - 10 of 10 Posts
Top