BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
Hey guys, here's the situation. I've noticed recently (past couple of days) that my car seems to be idling just a hair on the rough side when at a red light. It appears to be about 750 rpm in drive (approx). Is this normal? Also, my AC is not blowing cold at idle. Only when I pick up speed or increase the RPM in neutral. Is this common? Is my AC not putting out because my idle is too low or is my idle low because my AC isn't putting out? What should I check? I only seem to notice it when it's hot outside (90+ F) In the morning when it's in the 70s, it seems ok.

Also, why the heck does my alarm keep going off? It just started this a few days ago as well (about the same time).

Thanks for any help and info!
 

·
Registered
Joined
·
63 Posts
does your alarm go off when you try to enter your car? maybe you should check your battery terminals. gotta be nice and tight.

rrb.
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #3 ·
nope, it goes off at random with nobody around. All windows up. I know this sounds crazy, but I think it might have something to do with the heat. I drive around, ac running, then stop in 100+ degree heat with a dark green car and set the alarm. It could be 2 minutes, it could be 10 or 30. Just random.
 

·
Registered
Joined
·
221 Posts
The rough idle could be a number of things, mine recently was a vacuum leak, eventually traced to the intake manifold gasket. As for the AC, it could be low on coolant. I think the compressor runs based on engine speed, so if it is low on coolant it would provide less colling at idle then at higher RPM's. Just a guess though.
 

·
Registered
Joined
·
168 Posts
I too, have the alarm problem, maybe we need to start a thread...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top