BimmerFest BMW Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Last weekend I had to drive home from school, which is two hours away. The entire way home my car ran fine and no lights came on indicating any problems, but once I pulled into my driveway and turned the car off my car started to go off like crazy. I had the indicator flash up for Low Oil Pressure, Low Oil Level, and Low Coolant Level all at once. I look under my car after seeing smoke coming up from the underside of the car and see oil just flowing out of the engine compartment. Opened the hood and it looks to have been coming out from the front of the engine on the passenger side, seemed to be from the bottom of the engine. But I had oil all the way down the frame to the rear bumper from it just dripping down while doing 70 mph home. Seems like a real serious issue here and was wondering if it sounds familiar to anyone who may have had the same thing.
 

·
Wrenchin' guy
Joined
·
429 Posts
oil leak

:smokin:

dude,

you may or may not have the following problem,,,,,,

loose or missing oil plug at pan.

gasket failure at timing cover. or oil pan,

I have 525i with M50 motor.....I replaced every gasket so far ( have several posts here about the project) ,,,now I have no more leaks.....

it is time consuming if you elect to do it yourself, or get it towed to a shop and have them fix it....got to german auto specialist or to BMW dealer dont go to a midas or firestone, goodyear etc.

good luck with it sir!

:smokin:
 
1 - 2 of 2 Posts
Top