BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6,660 Posts
Discussion Starter #1
My radio has started acting up once every so often....when I start the car it powers up but no sound...turn off the key and restart the car and it comes back on....I talked to my mechanic and he said its the ignition switch....a $45 switch and about an hours work.

Anyone else here have this problem?

My car has 109K if that makes a difference
 

·
Registered
Joined
·
1,564 Posts
dboy11 said:
My radio has started acting up once every so often....when I start the car it powers up but no sound...turn off the key and restart the car and it comes back on....I talked to my mechanic and he said its the ignition switch....a $45 switch and about an hours work.

Anyone else here have this problem?

My car has 109K if that makes a difference
That is the solution to a litany of electrical gremlins so it is a reasonable thing to do. The other source of problems is a dying battery.

Bill
 

·
Registered
Joined
·
6,660 Posts
Discussion Starter #3
BillP said:
That is the solution to a litany of electrical gremlins so it is a reasonable thing to do. The other source of problems is a dying battery.

Bill
Thanks I called and will have the work done on Friday then watch the battery think I will have them check that at the same time just in case
 

·
Registered
Joined
·
192 Posts
Replaced mine. It cured the problem with my radio, turned off my air bag light, and fixed my non-functioning rear window powered sun shade. A simple fix that clears up a lot of problems.
 
1 - 4 of 4 Posts
Top