BimmerFest BMW Forum banner
21 - 38 of 38 Posts

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #22 ·
Automotive lighting Hood Motor vehicle Automotive design Automotive mirror

no error but it looks like there is a voltage issue… about 5 mins into a 30 minute drive the voltage dropped to zero for a second or less…..since i just replaced the reservoir im not gonna replace the alternator or regulator yet, id like to see if the error returns first
 

·
Super Moderator
Joined
·
9,935 Posts
Strange that it would go to zero, but I have seen under voltage faults before. The VR usually puts out excess voltage. The modules are designed to run at very close to 5 volts, anything off of 5 volts throws a fault. Try checking out the voltage at the jump terminal, just to see if you get a different reading?
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #24 ·
found an issue: my battery was listed as the wrong capacity and not charging correctly, its a 100ah agm and was listed as a 90ah agm,,, state of charge averaged 56% / 12.1v at rest and even got down to 48% 4 days ago, changed it to 105ah agm and SOC is now 76% and 12.5v at rest,, heading in the right direction!
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #26 ·
BMW owners have an uphill battle when replacing the battery with a different type,, in researching the process i found ALOT of different procedures, opinions, advice etc…. across many models! i did find this on the e90 board which spelled out the system facts and references the e63/e64 specifically
 

Attachments

·
Super Moderator
Joined
·
2,201 Posts
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #28 ·

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #29 ·
finally registered and coded!
reading the link above…. what is the choice for the N62?


Appendix A:
MSV70,MSV 70.0 for N52 (NG6),
MSV80,MSV 80.0 for N52KP (NG6),
MSD80,MSD 80.0 for N43 N53 & N54 with EWS4/CAS,
Mevd172KW, Mevd 172 for N55 (Older N55***8217;s up to late 2011 production)
Mevd176k, Mevd 176k for N55 (late 2011 production date or newer)
MSS60,MSS60 for S65 (M3),
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #31 ·
haven’t had a dynamic drive error in weeks, but sitting at idle it popped up again accompanied by 2DEB: power management….. so finally ordered a replacement alternator (fcp free lifetime replacement) and found the valve cover was leaking onto the alternator,,, pulled the cover and replacing the gasket and orings…. fingers crossed!
Motor vehicle Hood Automotive design Vehicle Car

Land vehicle Tire Automotive tire Motor vehicle Hood

Crankset Automotive tire Gear Motor vehicle Differential
 

·
Super Moderator
Joined
·
9,935 Posts
That does point to the alternator for over & under voltage problems. This would trip the DD warning on the dash. Is that a new, or rebuilt alternator they sent you? The joys of pulling a valve cover in the summer heat is not fun. Are you going to replace the upper timing gasket also? If it leaks at the blocked off pressure port in the upper timing cover, it will pour a lot of oil out, & soak the alternator.
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #33 ·
i did the upper timing cover a few months ago, that cured most of my leak,, apparently the valve cover was leaking at the corner right over the regulator,,, valve covergasket was brittle and worn. alt is new… putting it back together next week
 

·
Registered
2005 645ci
Joined
·
231 Posts
Discussion Starter · #36 ·
running good except: belt squeal,,, tensioner seems to have failed, it’s noticeably weak, ordered a new one, belt and idler. have a code, 2B65 camshaft sensor 2 outlet.
valve cover is sealed which is great, i noticed the hydraulic line has a connection right above the alternator, im gonna sleeve it just to prevent any more fluid from getting into the alternator as it seems to be critical to the operation
 
21 - 38 of 38 Posts
Top