BimmerFest BMW Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
So just by the title another N52 idle problem

Car just started acting wierd as in idle HICCUPS 30 RPM ⬇ every 3 seconds.
Feels just like misfire but with no codes stored.

Actions taken: Replaced 6 Spark Plugs ,
6 Ignitions Coils ,
Valve Cover Gasket along with timing chain (BMR Dartford) (UK)
New Vanos Solenoids.


Nothing changed car continues to hiccup every 3 seconds in P/R/N/D Even when rev holding at 2K
BMR said to me that it's the injectors but I highly doubt it because , yesterday i Disconnected the ECCENTRIC SHAFT sensor , started the car , idle was perfect , no more Jerking or Hiccups.

by disconnecting the sensor the car did throw 3 codes , but it's because sensor was disconected.


Question is , can this Sensor cause this sort of hiccups without throwing fault code?

Video 1 (will upload more videos tomorrow)

Rectangle Font Screenshot Parallel Slope

Rectangle Font Slope Parallel Number

Rectangle Slope Font Parallel Plot

Rectangle Font Parallel Slope Screenshot
 

· Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Did you reset the adaptations on the motor with the new Vanos solenoids. The DME does not know they are new, & is trying to adjust them like the old ones that were installed.
Have not tried to reset vanos solenoids ,
only valvetronic relearn limits.

Will look tomorrow in INPA or ISTA
for the procedure on how to 🤞
 
1 - 6 of 6 Posts
Top