BimmerFest BMW Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am stumped !

I have no spark or fuel. My engine turns over. After reading many threads here, the most obvious fix was the crank sensor. I replaced it and still same problems. I checked the relays. Fuel pump relay and DME relay works, However no power in the DME relay socket. I put a peake code reader in and it only shows error. After several various attempts I did finally get a "check engine" code. (cE) My dash lights do not show any check engine light even when my key is in the on position. Short of replacing the DME, which I dont think is the problem, I am stumped. The only other problem that surfaced is my driver side door lock is not working and I know that this is part of the security features of the car. Could this be the root of my problem and if it is , how can I test for this.

Thanks in advance for any suggestions....

A.T.
 

·
Turn Burglar
Joined
·
12,282 Posts
I am stumped !

I have no spark or fuel. My engine turns over. After reading many threads here, the most obvious fix was the crank sensor. I replaced it and still same problems. I checked the relays. Fuel pump relay and DME relay works, However no power in the DME relay socket. I put a peake code reader in and it only shows error. After several various attempts I did finally get a "check engine" code. (cE) My dash lights do not show any check engine light even when my key is in the on position. Short of replacing the DME, which I dont think is the problem, I am stumped. The only other problem that surfaced is my driver side door lock is not working and I know that this is part of the security features of the car. Could this be the root of my problem and if it is , how can I test for this.

Thanks in advance for any suggestions....

A.T.
Well, I read your thead title and opened the thread to say "check teh crank sensor, duhhh dood!" but since you already thought of that... Welcome to the Fest and great first post. We'll have you straightened out in no time. :thumbup:
 

·
Hellawut??
Joined
·
14,551 Posts
congrats on finding bimmerfest.... and yeah someone will help you...


are you sure your battery is fine? fully charged?

check make sure wires are all connected like check both sides of the wires with a volt meter.... make sure they go in the right ports.. then try again??
 

·
I Am The Machine
Joined
·
20,931 Posts
Welcome to the Fest!

A 95 has EWSII so the security system could be completely disabling the DME power. To me, I think you're correct on the guess about that. What exactly is wrong with the driver's door lock, and how have you been getting around that?
 

·
Turn Burglar
Joined
·
12,282 Posts
Welcome to the Fest!

A 95 has EWSII so the security system could be completely disabling the DME power. To me, I think you're correct on the guess about that. What exactly is wrong with the driver's door lock, and how have you been getting around that?
Awwww sh*t son, EWS- good call Chad.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
The key lock has been inopperable since I puchased the car. (driver side) The passenger side door lock would lock and unlock the car without any problems. The day before my problems I noticed that the door lock would not function using the key from the passenger side. If I am inside the car, I can push down on the lock and it will lock the car. Again , the key will not work to unlock that door. I dont know how to rule out this problem as the cause.
Thank you for your prompt reply to my problems And the other posters as well !!

A.T.
 

·
Registered
Joined
·
2 Posts
Bmw crank sensor replacement

2000 e46 crank sensor replacement, this did not fix the no spark and no fuel issue, but the video shows you how to replace the sensor.

 

·
I feed trolls
Joined
·
4,976 Posts
Nice first post :thumbup::thumbup:

That said, I suspect EWS is the problem as well. However I dont believe it has to do with the locking. Do you have the valet key and spare as well? If those dont work, I would suspect the lock cylinder. The reason I dont call EWS out on this one is because I would think it would disable the central locking system (or whatever it disables) and you wouldnt be able to get in at all. As for a fix, try bypassing the EWS. I dont have a link, but theres a way to do it, and it works well from what I've read. I think it requires jumping some wires on the DME, but Im not positive
 

·
Registered
Joined
·
2 Posts
Thanks driveby, goodman! I appreciate the troubleshooting info. I actually gave up and sent the car to the local bmw dealership for repair. They haven't concluded what the exact issue is yet, they were not getting a response from the DME, which I suspected when I used an OBDII, it produced an "Error" message. There next step was to remove the after market alarm system, which must have done something because they did get it started today, but mentioned they did not know how or what exactly they did to get it started. I will find out tomorrow hopefully what the cause was specifically. I am very worried what the cost of this repair will be. I will post the findings and cost soon. Thanks again!
 

·
I feed trolls
Joined
·
4,976 Posts
Thanks driveby, goodman! I appreciate the troubleshooting info. I actually gave up and sent the car to the local bmw dealership for repair. They haven't concluded what the exact issue is yet, they were not getting a response from the DME, which I suspected when I used an OBDII, it produced an "Error" message. There next step was to remove the after market alarm system, which must have done something because they did get it started today, but mentioned they did not know how or what exactly they did to get it started. I will find out tomorrow hopefully what the cause was specifically. I am very worried what the cost of this repair will be. I will post the findings and cost soon. Thanks again!
Im gonna guess around a grand... Aftermarket alarm + EWS = not good. Dont let them sell you on a new DME now either, because if they got the car started, the DME is just fine
 
1 - 11 of 11 Posts
Top