BimmerFest BMW Forum banner
  • BimmerFest Mobile App is now available on iOS & Android, Learn More

A/C and Heater no airflow

1653 Views 12 Replies 5 Participants Last post by  BROOKSBC
So I just changed out my water pump and the hose that connects the water pipe to expansion tank due to overheating a leaky hose. I put it back together and the problem was fixed. no more overheating and no more leak but since i put it together this problem started immediatley.

I have no airflow period. No A/C airflow and no heat airflow. The condenser kicks on but i get no blow. Checked all my fuses and they are good.

Am i looking at a blower motor or a blower motor resistor? Its 95 degrees outside and windows down just will not cut it. Can i get some suggestions please?
1 - 9 of 13 Posts
Yes vents have been selected. The blower does not come on. As I change from one vent position to another I can hear the motor change the direction of airflow but that is it. Another thing, i put my head down under the glove box near the relays that are behind it. I cant hear them click on or off as i turn on the HVAC.
Sounds like an FSU issue
Thats what i am thinking now. I have been thinking back in the past few weeks and my airflow has been erratic but i never thought twice about it being an issue.
I got one on order. I looked at the DIY and I think I can manage it with a few profain words
Would my ABS, DSC, and Brake light coming on have anything to do with the blower not blowing. Because when I hooked the battery back up they came on
Changed out FSU but it didnt fix or change anything. Still no air blowing. Any suggestions?
Yes they are. Battery is connected solid. Alternator is brand new in march or April
Also i just swapped out the relays behind the glovebox but no luck there either.
Fixed it. After tearing everything apart to try and dig the blower motor out I noticed the color of the power and ground wires leading to the blower itself. Coincidentally they were the same wires that plug into the harness on the fan shroud i had to remove in order to change the water pump that i mentioned in my initial post and found that it was not seated all the way. Plugged in and turned the key on and now it works. ******BUT i still have the DSC, Brake and ABS lights on my dash*******

Thanks for all the help along the way to everybody anyway!!
1 - 9 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.