BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just had both of my rear wheel bearings replaced at a local shop, not a BMW dealer. Now the ABS, BRAKE, and one more warning light are on. I can't use cruise control. I believe that a sensor was damaged or not hooked back up properly? Does anyone have any ideas for an easy fix for this? Is there any way to bypass/turn off this warning so I can use cruise control? Thank you for any suggestions.
 

·
Breaking in the Pony
2019 Mustang GT / 2005 Toyota Tacoma
Joined
·
6,314 Posts
I don't believe there's any "quick fix" for a wheel speed sensor fault. If it came about as a result of a repair, I would think the shop is on the hook fixing for it, either by repairing the sensor or connection they damaged.

One thing I am pretty sure of is that if there's an ABS issue, cruise control is offline. You'll need to get it fixed before cruise comes back.
 

·
Registered
Joined
·
8,080 Posts
The wheel speed sensor harness is known to become brittle over time and when any work is performed near it, it often breaks the insulation/wiring or it shorts itself.

As mentioned, cruise control will not be active until the sensors are replaced.
 

·
Banned
Joined
·
10,015 Posts
I just had both of my rear wheel bearings replaced at a local shop, not a BMW dealer. Now the ABS, BRAKE, and one more warning light are on. I can't use cruise control. I believe that a sensor was damaged or not hooked back up properly? Does anyone have any ideas for an easy fix for this? Is there any way to bypass/turn off this warning so I can use cruise control? Thank you for any suggestions.
Some educational info
 
1 - 4 of 4 Posts
Top