BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Roar Lion Roar
Joined
·
235 Posts
Discussion Starter · #1 ·
Last fall when I purchased my 1995 325i vert, I noticed that it was only blowing cool, not cold air when the AC button was activated. Took it to an indy I trust and he gave it a shot of refrigerant and dye and told me to come back in the spring if it is not working and he would check for leaks.

Well, today it was a bit warm so I figured I would give the sysytem a try. Low and behold no cold air. Question is is this something I can fix if it is only a leak. Since there was dye i the system where should I start checking for leaks?
 

·
Registered
Joined
·
12,430 Posts
due to the age of the vehicle, i suggest a proper diagnosis. just a 'squeeze-n-go' will not be sufficient as my experience has been that the accumulator (which acts as a filter) seldom gets replaced, which can reduce the ac system efficiency.

if you do need a service, i suggest getting an evac and recharge, accumulator, and system reseal. when i did my services i would always suggest this as part of the repair.

if your service tech does not at least suggest doing this, then i would suggest looking for a more thorough tech.

now to answer your question, yes, you could probably do your own 'sqeeze-n-go' service but unless you actually understand how the system works you are not properly fixing the issue, just a temporary patch at best. if you do this, though, i suggest using a can with some oil in it to help lubricate the system.

good luck.

df
 
1 - 3 of 3 Posts
Top