BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, Im quite new to this so forgive me if i commit some terrible faux pas.

i've had the car for about a year and the air conditioning has never worked due to a hole in a pipe so no pressure, it hasn't bothered me up until now but summers comin round again so....

I finally got round to replacing a few of the air conditoning pipes and had the system serviced and repressurised and there's no leaks or anything but it just doesn't blow cold air.

My local garage said they didn't have a clue so i thought id better ask on here

i've read about replacing the fsr but i'm not sure if thats just for fan speeds changing wildly or if i'm even close

any help would be much appreciated and i thank you all in advance

great site, keep up the good work!!

cheers

jay
 

·
Registered
Joined
·
80 Posts
is the ac compressor good? and is the ac belt/pulley worn? You can completely recharge a system and have good freon in it, but it wont work with a bad compressor. and the FSR will only affect the interior fan speed.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Have checked belt

Have checked the belt and pulley and they seem fine, how would i go about checking the compressor?

cheers
 

·
Registered
Joined
·
80 Posts
the only way you can no for sure is to have a professional trouble shoot it. I used to work in HVAC, and basically if everything else works just fine its probably the compressor. bearing noise is a good hint that it is the compressor. a pressure test will only tell you that there are no leaks.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top