BimmerFest BMW Forum banner

Alternator going bad?

1024 2
Hey guys, so for the past month I have been having a problem with my 7. The car wouldnt start, it would give me parking error and ABS error and transmission error so I had to turn the car off and then jump start it.

After a while even after the jump start it wouldn't work, good thing I had a jump starter kit so I had it connected and drove with it connected to the battery for a few minutes then disconnected it to avoid getting the errors mentioned earlier.

Battery was tested good, so I thought it was the alternator but before replacing the wrong parts I went with the cheapest fix first which was replacing the battery. Cost me almost $35 for a rebuilt battery (no difference whatsoever from past experience) and my problems are gone.

Its been about 2 weeks and the 7 is running great, operating voltage is higher 13s or lower 14s. The only problem is that every once in a while I get an error saying GENERATOR FAULT in the mornings and the voltage drops to 11s.

I have done some research on the forum and I know that the problem is mainly the alternator, but what do you guys think? will I have the same problems again?

The battery is not registered either, where can I get that done and how much does it cost?



Thanks guys :thumbup:
1 - 3 of 3 Posts
Man, I would be scared to put battery like that in the power hungry car like 7
I bought one from Autozone for about $160 registered it,it didn't resolve my problem,so I replaced the Alt, bought it from Ebay brand new for about $290 (Valeo,aircooled)and replaced it myself.
Try finding someone in your area,familiar with INPA to register your battery,then go from there,good luck.
thanks bro, well my dad is a mechanic and he has a shop and we have always used those rebuilt batteries and never had any problems with them, and its the same with the 7 so far. I will try to find someone to register the battery then, will try the dealer first lol its just interesting how much would they charge for something so simple.
Man, I would be scared to put battery like that in the power hungry car like 7
I bought one from Autozone for about $160 registered it,it didn't resolve my problem,so I replaced the Alt, bought it from Ebay brand new for about $290 (Valeo,aircooled)and replaced it myself.
Try finding someone in your area,familiar with INPA to register your battery,then go from there,good luck.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top