BimmerFest BMW Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I usually play music from a USB stick plugged into the arm rest USB, however it has stopped working, there is still power coming from the USB port as I can charge my phone but it will not play music, it did randomly start working again the other day but since then nothing. I have a 2009 e92 330i
 

·
Registered
Joined
·
54 Posts
I'm having the same problem, except my USB inside the glove compartment isn't working either :(. I have a 2011 335is vert
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
My USB started working again a while back, however it has just stopped working again. Is there any way i can check for error codes using carly/INPA? Not sure if it helps but this is the module in the boot:

 

·
Registered
Joined
·
773 Posts
Is this issue happening with one flash drive that you have been using? Or have you tried using a different one and still get the same issue?
 

·
Registered
Joined
·
6,109 Posts
You would need a BMW Scanner to scan for codes regarding the IBS.
Inpa or Carly should be fine.
You need to voltage check the battery but better to load test it.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #10 · (Edited)
You would need a BMW Scanner to scan for codes regarding the IBS.
Inpa or Carly should be fine.
You need to voltage check the battery but better to load test it.
I have INPA but i have not used it to diagnose the IBS before, is it fairly simple to do? just a matter of selecting the module? I also have Carly and a general scan doesnt show any codes related to the battery/IBS.
 

·
Registered
Joined
·
25 Posts
Just my 2c, and ignore me if I am wrong, I have done "some" extensive research on the topic of the USB for my own issue so lets cover some of the bases.

I had a similar problem with the exception that it was iPod connectivity (my HU was unable to read any song data/give me steering wheel control exception of vol) related and it sorted itself out somehow with me fiddling around with the different connections, not very technical, but the last thing I did in my frustrations before the issue went away was to get behind the center console, pop up the usb/aux port unplug the USB port side and replug it in making sure that it locked in place

I am not educated on the options of your car nor how much they differ by Euro-spec vs my US-Spec, but ill give it a shot, it would make the process quite a bit easier if you have BT connectivity, with no BT connectivity (SAYING YOU HAVE BT), I would assume your MULF2 (Module in the trunk, controls to my knowledge Steering wheel entertainment control/Exception to volume, BT Connectivity, USB Port Read Data, I heard but not 100% sure PDC?) of the car has failed, NCS Expert can not read the module (how I know? I was an idiot before I became intelligent enough to realize google needs some specific key words to work well), I believe INPA can though but have not tested it out. If the car does not come equipped with BT I would go through all the checks on everything before going out to buy a new module (I was impatient and picked up a used one before I found out it was not the issue, I have a $100 extra part sitting in my trunk for fun now...)

Finally the connectivity of the USB port, following the line down into the drivers side footwell, you "should" (again my car vs everyone else's) encounter a "USB HUB", if there, there are 2 ports in the rear side, 1 being used 1 not, you can attempt a fix by switching the USB Port to the unused Port in the HUB and see if that fixes it.

My knowledge is relatively scattered and fixated on my issue but all in all USB Port -> USB HUB -> MULF2 (I believe) are all the modules with exception to the actual HU. Good luck!
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #12 ·
Hi mate, thank you for the reply!

Just to update you, i ordered a usb lead off ebay that fits my car, this lead plugs directly into the MULF 2 in the boot, when testing this i was able to play music from a usb! this must mean that the issue is between the usb in the arm rest and the MULF 2. I will try and find the USB hub and see if im able to swap the connections, otherwise ill have to put up with having my usb in the boot! I also do have BT which still works so i knew the MULF 2 wasnt the issue.

I guess the only options left now are the usb port itself or the usb hub?

thanks for the help :D
 

·
Registered
Joined
·
25 Posts
I've heard a multitude of things about the USB HUB and its actual location, from under the carpet, to simply cars not having them, unfortunately if the issue is not your MULF2 and not the actual USB port itself, I'm afraid you might just have to pull up the carpeting to reveal the lines running from the arm rest to the MULF2 in the boot.

To be honest though, if it were me, and the USB lead works and music is playing, I'd leave the flash plugged in, in the boot under the floor mat and forget about it, until of course I want to update my music, to me it's cleaner without a flash sticking up and out of the arm rest whenever I open it. Of course until I want to have some fun one day.

If it does end up the USB port is working and you have to pull the carpet/center console/drivers side kick panel to play hide and go seek with the USB hub or if you simply don't have one to begin with, an update would be super helpful!

I know this sounds basic but have you tried prying up the USB port itself and replugging it in? The plug does stand vertically and despite how strong I'm sure the clips are to hold a tiny cable, eh worth a shot?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #16 ·
I agree, at the moment having the usb in the boot is fine with me. I will at some point try replugging in the usb port and also checking behind the drivers side kick panel. Ill make sure to update on here with my findings.

Thanks for the help! :D
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #17 · (Edited)
Hi Guys, couldnt find anything behind the drivers side kick panel, have a new usb port on the way so will test that out when it arrives. Cheers

*update* ive just checked the usb socket from the arm rest using a multimeter and it doesnt seem faulty. Any other ideas where the USB hub is so that i can check it? unless its a damaged wire it has to be the hub.
 

·
Registered
Joined
·
25 Posts
There seems to be quite a lot of guesswork unfortunately regarding this thread, would love for someone who actually has one and has seen it to post but until then.. I've seen a diagram of the HUB being under the drivers side carpet LHD (US Spec) mounted inside of a white/opaque box, and I swore I read someone posting it was under the passenger side carpet for RHD cars, again all guess work haven't seen evidence/proof, to simplify life and make it a 5 minute job I'd pull the seats (both driver and passenger) all the way back, pry the side trims up and take a flash light and peer under the carpet for it. Sorry, I feel quite unhelpful as I myself have never seen it myself and am going off numerous posts which 1/2 are probably are as uninformed as I am. Good luck.


Sent from my iPhone using Tapatalk
 
1 - 20 of 22 Posts
Top