BimmerFest BMW Forum banner

Auto to Manual MS43 Swap

4330 Views 4 Replies 4 Participants Last post by  marcozandrini
I got my hands on a spare ECU from an Auto E46 (MS43), and I decided to use it as testing grounds for flashing, tuning and that sort of stuff. Now my car is manual, and so I don't think it's a direct swap in.

Here is an issue: The car won't start, it is cranking, but doesn't run.

Here is what I read so far: For the spark to engage all modules in the car need to be synced and that's what is probably causing an issue

And here is what I did so far: First of all, before doing anything to the ECU, I put it in the car and gave it a try, the car did NOT start. I figured ok, that's sort of expected :). So the car I sources the ECU from was a 325 I think, so I put in in boot mode (following a tutorial), flashed it with M54B30 (like mine) .bin file and put it all back together, and that did not work, the car still only cranks, but does not start :dunno:. After some more googling I found out the thing about different modules, and attempted to remove the pesky automatik module using NCSExpert, I went through and found that automatik module is not even in the path. SO I'm kind of lost from here, NCSExpert isn't even supposed to help, the car should start as is with an engine light.

I also read that I might need to "Clear adaptations" with INPA, so I did that as well. And yet again, nothing... :mad: So after roughly 16 hours I'm here. Any experts on this? Anyone done this before? I don't want to assume the ECU is bad before I know it.
1 - 5 of 5 Posts
You might be better off in the coding sub-forum, which can be found here: https://www.bimmerfest.com/forums/forumdisplay.php?f=175
Didn't know there was such subforum, thanks.

Sent from my iPhone using Bimmerfest mobile app
You might be better off in the coding sub-forum, which can be found here: https://www.bimmerfest.com/forums/forumdisplay.php?f=175
Top left corner of every page, you`ll see "BMW FORUMS"....click on that, you will get the complete drop-down menu....
Didn't know there was such subforum, thanks.

Sent from my iPhone using Bimmerfest mobile app
Also, I believe the EWS (theft prevention system) needs to be coded to reflect that the car has a manual transmission. Go to Bimmmer Forums and search for a swap thread that contains “EWS.”
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top