Bimmerfest BMW banner

1 - 14 of 14 Posts

·
In Mod Heaven
Joined
·
2,763 Posts
Discussion Starter #1 (Edited)
New Car Back at the Repair Shop!!

Well, I have had my car officially four days now and it has spent almost 1.5 days at the repair shop. One day on Tuesday b/c of the see here (New Car Pickup & Problems) and I ended up taking the car back today.

I drove out to PA for a meeting and there were no problems at all; actually I haven't had any problems since the car was at the shop on Tuesday (less than 12 hours after picking up the car!) and noiting was done to it except resetting the computer. It was raining like crazy all day and the car was fine until I got back into Buffalo. I stopped at an audio install place and when I left, the car started acting up again. This time I was at a light and the throttle kept revving between 1-3K rpm's. I shut the car off, back on and no problems until after I got home. I went back out to pick up my friend and the car's throttle got very touchy. Same thing as before, I'm at a light and the car bounces between 1-3K rev's. I shut the car off, back on, and again its fine for about a minute or so. I had to do this about 5 times (the last time the warning lights came on - brake and EML). I shut down the car, called my salesman and said I was bringing the car in. Once I started the car back up to goto the dealership, no problems. . . it figures!

I should mention that the only times that the cars seems to be acting up is after driving it in the rain. When I took delivery on Monday, it was raining and the car was fine until after driving it a few hours. The next morning, the same thing - raining out, all hell breaks loose with the throttle and the warning lights. Tuesday afternoon thru Wednesday its clear out and no problems whatsoever. Today it rains like hell and the car acts up.

I told my salesman all of this info. I also told him I don't want the car back until it's fixed and that I don't want to hear the same line of crap as before "We can't duplicate the problem so there isn't much we can do about it". I told him if they have to replace the computer and throttle body that they should just do it. I also said that I don't want to have to come back every other day. . . It's a brand new car for Ch*** sake! I was calm on Tuesday but now I'm just getting pi**ed off!

After I picked the car up last time, they said if it acted up again, they would need it for a few days to see if they can duplicate the problem. I really don't want them racking up miles on my car over the next few days; that and the fact that it will be sunny thru at least Sunday so I have a feeling the car will be fine.

Sorry to rant on so long but I just got home with the loaner (330i - auto) and I'm still wound up.
 

·
Registered
Joined
·
1,523 Posts
Trust me, those who have had any sort of problem with their e46 knows the feeling you have right now. It sucks dropping a lot of money and waiting months only to have a problem or inconvenience.

Hang in there. Your problem seems central...computer....I'm sure it'll work out. Enjoy the loaner car and learn the e46's nuances without beating on your own car

Also, read up on Lemon Law in NY State.
 

·
Registered User
Joined
·
10,856 Posts
At least you missed the fan debacle. Within the first three months I had MY car, I was driving a 740i or a loaner 328i for a grand total of TWENTY-EIGHT days! (Nice cars, but all had pansy trannies.)
That was fun. :p
 

·
Bayerische Motoren Werke
Joined
·
1,002 Posts
Ack,

That truly sucks. Hopefully they will ante up and just change the throttle and computer unit even if they arent sure its causing the problem. I dont see the reluctancy to do so, they can charge this back to bmwna for warranty work. Such a shame this has to happen but nothings perfect in this world, especially BMW's. Maybe you can get them to throw in some freebies for this *hit you're having to deal with. Anyway, hang in there, theyll have it corrected soon.
 

·
Crazy Canadian
Joined
·
1,095 Posts
Man that's exactly the type of BS my dealership gave me(with the same problem.)

Tell them to get off their butts, hook the computer up, diganose the fault code and realize that it's the throttle control valve.

My work order says that they replaced the complete throttle valve assembly.

There WAS a TSB on this a long time ago. It's a problem that's never completely gone away from what I gather.
 

·
In Mod Heaven
Joined
·
2,763 Posts
Discussion Starter #6
Bol - what year car do you have?

I will end up talking to the service manager this morning and I will ask them to change our the Throttle Valve Assembly. Have you gotten your car back yet? If so, has this corrected the problem?

I still can't believe this is happening so soon into taking delivery of thiis car. :( I just don't want to deal with any run-arounds any more. I will take your advice and spell this out when I speak with the SM. I'll post later today to let you guys know what they say. I hope they won't have the car over the weekend, I have a bunch of friends up for graduation and they really were looking forward to checking out the car.

also . . .

bol said:
There WAS a TSB on this a long time ago. It's a problem that's never completely gone away from what I gather.
What exactly is a TSB?
 

·
In Mod Heaven
Joined
·
2,763 Posts
Discussion Starter #7
02330ci said:
Ack,

That truly sucks. Hopefully they will ante up and just change the throttle and computer unit even if they arent sure its causing the problem. I dont see the reluctancy to do so, they can charge this back to bmwna for warranty work. Such a shame this has to happen but nothings perfect in this world, especially BMW's. Maybe you can get them to throw in some freebies for this *hit you're having to deal with. Anyway, hang in there, theyll have it corrected soon.
This is what I will ask them to do. It is all covered so I don't see what the problem is. I don't understand if the BMW mechanics are more technical service guys than anything else . . . read some error codes, look them up in the manual, diagnose and replace problem manual refers to. What happened to the days where you would explain a problem, and they could diagnose from this. I know BMW's are mostly, if not fully run by electronics and computers, but . . .:thumbdwn:
 

·
Crazy Canadian
Joined
·
1,095 Posts
Ackster said:
Bol - what year car do you have?

I will end up talking to the service manager this morning and I will ask them to change our the Throttle Valve Assembly. Have you gotten your car back yet? If so, has this corrected the problem?




What exactly is a TSB?
I had a 2001 330Ci and I had this specific problem about five months ago. After they replaced the complete throttle valve assembly per their work order, the problem never showed up again.

A TSB is a Technical Service Bulletin, pretty much a document that describes a problem and its resolution. It's issued to the dealerships so that common problems can be addressed quickly.
 

·
Registered
Joined
·
2,109 Posts
Re: Repaired (I hope!)

Ackster said:
BMW just called me and they said they controlled the Idle Control Valve and that the car is all set. I will let you guys know if the problem arises again. I hope everything is ok.
Good luck with yours. I'm getting mine worked on Friday morning. I'll post the results.

Sounds like an epidemic.:eek:
 

·
In Mod Heaven
Joined
·
2,763 Posts
Discussion Starter #12
Re: Re: Repaired (I hope!)

Topaz330xi said:


Good luck with yours. I'm getting mine worked on Friday morning. I'll post the results.

Sounds like an epidemic.:eek:
Are you having the same thing done to your car? When did your problem start?

So far no problems whatsoever, since the repair. A weird thing happened though on the way home today. I turned on the cruise control and after about two minutes the trip computer dims for about 10 seconds. It returned to its natural lighting after this. I had my lights on and the back illumination did not change. Strange electrical things with the car. It's almost as if its alive . . . :eek:
 

·
Turbo Addict
Joined
·
87 Posts
I've had that same dimming...

I've had the same "dimming lights" on my '99 328i. It's got about 40k miles on it and nothing serious has come of it, but I plan to have them look at it when I bring it in for its last warranty service. Strange. Lights on trip computer and radio fade away almost to off and then jump back to life over about 10 seconds or so. Radio volume stays the same and everything else (including headlights) seems fine...strange. At least it seems like a localized problem. I'm not bringing the car in probably for a couple more months, but I'll post if anything comes of it. :dunno:
 

·
Registered
Joined
·
2,109 Posts
Re: Re: Re: Repaired (I hope!)

Ackster said:


Are you having the same thing done to your car? When did your problem start?

So far no problems whatsoever, since the repair. A weird thing happened though on the way home today. I turned on the cruise control and after about two minutes the trip computer dims for about 10 seconds. It returned to its natural lighting after this. I had my lights on and the back illumination did not change. Strange electrical things with the car. It's almost as if its alive . . . :eek:
Not sure if it's the same exact thing or not. I'll post the results of the work order when I get it back. The part was ordered and they said it would take a couple hours on Friday.
 
1 - 14 of 14 Posts
Top