BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I am installing the Sirus receiver into my 330i and the directions state to disconnect the battery before I unplug/plug anything. If I disconnect the battery, will I need to have the entire car reprogrammed- like the OBC, the daytime running lights, the Homelink, etc??
 

·
kludge it!
Joined
·
628 Posts
No.
I've had the battery disconnected for more than 1 hour and nothing had to be reprogrammed, not even my radio stations.
The OBC and the car memory settings are not affected by prolonged battery disconnect.
 

·
There and back again
Joined
·
2,601 Posts
jaf211 said:
I am installing the Sirus receiver into my 330i and the directions state to disconnect the battery before I unplug/plug anything. If I disconnect the battery, will I need to have the entire car reprogrammed- like the OBC, the daytime running lights, the Homelink, etc??
No. All that stuff lives in non-volatile memory. A couple notes on general "disconnect the battery" things:

1) If you have NAV, you must wait until the light on the NAV computer goes out (90 seconds or so, max) before disconnecting power, or you run the risk of corrupting the memory in the NAV computer (it would need to be replaced in that case).

2) If you have an XI (I don't know if this happens on non-XI vehicles) when you reconnect the battery and start the car, you'll have a bunch of fault LEDs lit in the instrument cluster (ABS, DSC, etc.). Just slowly drive the car 100 feet or so and they should clear as soon as new inputs are seen from the wheel sensors.
 

·
kludge it!
Joined
·
628 Posts
Terry Kennedy said:
2) If you have an XI (I don't know if this happens on non-XI vehicles) when you reconnect the battery and start the car, you'll have a bunch of fault LEDs lit in the instrument cluster (ABS, DSC, etc.). Just slowly drive the car 100 feet or so and they should clear as soon as new inputs are seen from the wheel sensors.
Never had that happen on my 330i. Maybe it is an XI only thing.
 

·
They call 'em rigs here
Joined
·
859 Posts
I didn't disconnect the battery when I installed mine. Don't know why you would need to, but if the instructions say to... Of course, I only read the instructions as a last resort.
 

·
Registered
Joined
·
3 Posts
I have a 325i ,2001 ,and disconect the battery, but when put in back the panel dosent work ,dont have level gas ,dont work the meters , please help , thanks
 
1 - 6 of 6 Posts
Top