Bimmerfest BMW banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, just looking on some advice on where to bring my 2007 550i that has been giving me problems with my battery for some time now. Car would randomly give me ***8220;increased battery discharge***8221; message 1-2 times in the last few months and this past two weeks didn***8217;t start up. Jumped the car off, got her running and had a friend pull fuses and test them for a draw, no luck. Still showed a 5-7 amp draw. Tried unplugging front power supply to the car and the draw was gone, so expecting something in the car not turning off while the car is trying to sleep. Already tried unplugging IBS, load tested battery it tested good and had my alternator looked at. Next step is either bringing it to a local Indy shop(125 hr/ he estimated 1-2 hours) and the dealership they said 210$ for a diagnostic. Any advice on the route I should take?
 

·
Registered
Joined
·
367 Posts
Having learned personally about water ingress and how it screws up the electrical systems on these cars, I'd be mindful of that issue.
Might be a good idea to have the cars main and subsystems updated with latest software too.
Have you tried completely disconnecting the battery overnight to do a hard reset on all systems?
 

·
Registered
Joined
·
11 Posts
Mine is an 06 530XI and have been dealing with High Battery Drain since last year. Thru the summer I had no issues starting the car every morning, but recently I have been putting a charger on it every night because one day at work it would not start. Used a battery pack and got going. I get the message every morning even though I have the real, not trickle charger on the system (at the battery). One of the best investments you can make is the Carly app and OBD connector.

When the system senses the low battery - many of the computers get confused about their reason to exist. I had my steering wheel and shifter get locked in place - even though the car was able to start. Errors all over the iDrive display. Only by connecting with my Carly app was I able to clear the errors and get going. Not sure how else I could have done that. So Carly saved my day.

But I'm still confused how the system can have a battery charger connected all night and still lose the date / time and cd player. Trying to find my ECM (the small white box that is sometimes located in the trunk, under the tire). I'd like to change that out. But there are no posts about where that might be located.

Anyway - good luck.
 

·
Registered
Joined
·
367 Posts
For anyone else looking at this thread, I'm unsure if the sedans have the same rear wiring issues as the wagons, but that's another key area to troubleshoot. My new-to-me wagon seemingly has cut wires somewhere within the headliner that the dealership just repaired 3 years ago for the previous owner to the tune of $2700, but here I am again with the same issues. Rear wiper not working, rear hatch glass release not working. Previous owner invoices also pointed to recurring low battery voltage and 2 replacements in 4 years. Not normal at all, so obviously the wagons are prone to electrical system issues.
 

·
Registered User
2008 535xi wagon
Joined
·
2,944 Posts
I also have a high battery drain warning. Runs and drives and otherwise seems fine apart from the clock resetting and stuff.

I recall, hazily, that there is a method to pinpoint current draw, possibly via obd? Or do I need to pull fuses and hook up an ammeter?
 

·
Nuclear engineer
02/2012 X5 35d M57Y CPO 99K miles NOKIAN WR G3 12K miles
Joined
·
17,466 Posts
1 - 7 of 7 Posts
Top