BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
My Spoon Is Too Big.
Joined
·
323 Posts
Discussion Starter · #1 ·
So i recently replaced my alternator on my 99 323i.

after doing this, a few days later i began to hear the common "chirp" sound at idle rpms only, and it would go away when revving/driving.
So i began by replacing the idler pulley (deflection pulley), as well as the main belt tensioner, as well as the main belt.
After doing this, the squeal is now at ALL rpm ranges!
However, after driving for about 30 minutes, it seems to go away.


Its rather loud, and annoying.
However, i dont see any performance of the car being affected.

So i went ahead and took the whole a/c belt off and ran the car, and still is the same squeal.
Im left to think that perhaps my water pump bearings are going out?

Any ideas? Ill post a video soon.

P.S. the power steering pump pulley is brand new,
 

·
Registered
Joined
·
81 Posts
I had similar noise after I replaced the belts. So I replaced idler pulley, tensioner pulley and water pump pulley. The noise went away. I cannot pin point which part is the guilty party. For me, the plastic water pump pulley should be replaced.
 

·
My Spoon Is Too Big.
Joined
·
323 Posts
Discussion Starter · #3 ·
The other day i took my water pump pulley off and cleaned it as well as i noticed my power steering pump pulley bolts were loose. Tightened them and put it all back and the squeal is gone.

:) now to tackle my ambient temperature sensor fix, since it got ripped off :\

Sent from my SPH-D700 using Bimmer
 
1 - 3 of 3 Posts
Top