Bimmerfest BMW banner

1 - 20 of 21 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Based on posts in several forums, I decided to buy the Vgate 2 and the Bimmercode app.

My main desire was to get rid of the legal warning on iDrive and get the mirrors to auto-close. There were also a few other little things that looked interesting to me (was playing with the backup camera settings) so I did them at the same time.

When first coding, I got a few error messages , but they went away after restarting and then clearing codes with the app.

Today I noticed a check engine light on, so I wanted to use the app to clear it, but it would not go away. Something about cylinder 5, I don't recall the exact message.

Since I thought it might have been caused by the coding (don't know how, but wanted to be certain), I decided to restore from the backup that Bimmercode automatically makes for you.

THAT IS WHERE THE HELL STARTED. :mad:

The restore failed. Now my airbag says it has been turned off and will no longer work. I have been able to code new things, but none of the restores work. Restarting the engine does not reset it, and I cannot clear codes.

I am now regretting wanting to get rid of that annoying message. :(
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Just for kicks (mostly kicking myself), I started with a clean connect - airplane mode, only wifi on - and tried again. The app does recognize that 2 of the ECU's are corrupted now, so that is new.

I tried restoring the Advanced Crash Safety Module - it took 3 tries, but it seemed like it worked on the last try. The icon for that module is now green but the airbag lights are still on. The car access system still has a red icon for 'Coding data faulty'.

I have to say, backups are no good if you can't actually use them. I have no idea how much BMW will charge me to fix this.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I have been chatting through email with Bimmercode support, and have ordered a new Vgate module at his suggestion (bluetooth, this time). He fully believes that when I connect to it, I will be able to restore my ECU's.

I can't fault their support, and I hope this works.
 

·
Registered
Joined
·
2 Posts
Sorry to hear about your predicament.

I was in a similar situation with my previous car (X3 F25) while using Carista. In my case, the FRM module had been corrupted and none of the restore option worked. Carista also offered to send an adapter, but I didn***8217;t have the patience to wait. Fortunately, I found a guy who was able to re-flash the firmware and get it back to original state. Damage was a mere ~$200 and he threw in free coding.
 

·
Registered
Joined
·
6 Posts
I had a similar issue. Just bought a 2017 X5 and decided to get BimmerCode to do video in motion and auto fold of mirrors and comfort open and close of windows with key fob. So I ordered everything and went to work. As soon I tried to code the Headunit I got a coding error and the radio went black and displayed no signal. So I restored from backup which failed. At this point I***8217;m beside myself. What did I just do to my new BMW. On the 3rd try it went back to backup. So then I decide to try my luck with the mirror coding. All went better here and the coding was successful......but then as soon as it was done 3 error codes light up including a Brake warning, Chasis Stabilization warning and Park brake warning. WTF. So then I purchase the Bimmer Link app to clear all the codes and thank god it works. The coding allowed all the options to work that I chose. Everything seems to have been successful and now I have foldin mirrors at lock and unlock.......that night we leave on a trip and low and behold my Navigation is gone!***x1f61f; the coding wiped out my Navigation! With no support from the app and another company trying to sell me $150 Nav restore software I decide to try my luck at the dealer. I take it to them and say that when I started the car that day the Navigation was just gone. Totally played dumb. When they loaded my key fob in the computer it showed a code for the navigation so they would have to take my car to BMW Engineering. Long story short......my Navigation was restored and the codes from the mirror coding were also stored in the key fob, so the re-flash of that computer rendered my new mirror coding useless. But everything was fixed and for $0. My suggestion is leave BimmerCode alone and get your car coded either by a professional or through a site that does remote coding. For me it***8217;s not worth it. On another note just remember that even though you clear codes from the car your key fob stores those codes so BMW can see them. Good luck.
 

·
Registered
Joined
·
24 Posts
I just got around to doing my coding via bimmercode. I believe I got to my first error when I did the video in motion and several more errors with some other coding. At the time I was not aware of another app that folks purchase to clear the codes. My first thought was oh F, what wrong. But i turned the car off and back on and all the errors are gone and haven't come back in about two weeks. Am I all good, or is there some stuff going on in the background? No lights on, and everything appears as it did before I coded.
 

·
Registered
Joined
·
6 Posts
I just got around to doing my coding via bimmercode. I believe I got to my first error when I did the video in motion and several more errors with some other coding. At the time I was not aware of another app that folks purchase to clear the codes. My first thought was oh F, what wrong. But i turned the car off and back on and all the errors are gone and haven't come back in about two weeks. Am I all good, or is there some stuff going on in the background? No lights on, and everything appears as it did before I coded.
Mine was the same way, but the codes stayed in my key fob and the dealer can see them. Not sure if you have the same system. I have a 2017 X5
 

·
Jack Attack
Joined
·
183 Posts
I have been chatting through email with Bimmercode support, and have ordered a new Vgate module at his suggestion (bluetooth, this time). He fully believes that when I connect to it, I will be able to restore my ECU's.

I can't fault their support, and I hope this works.


I'm very curious if the Bluetooth Vgate worked for you. I also tried with a obd wifi but cannot connect to bimmercode at all. I think I bought the wrong one (need the Bluetooth) but now I'm hesitant reading this thread, so many of you getting errors and the navigation disappearing for another guy... I don't know if it's worth that risk to getting video in motion and my mirrors to open and close with my fob.... BTW I have a 2015 X5


Sent from my iPhone using Bimmerfest mobile app
 

·
Automotive YouTuber
Joined
·
22 Posts
I bought the Veepeak OBDCheck BLE OBD2 Bluetooth Scanner from Amazon (https://amzn.to/2NoAaTz), and used it with the Bimmercode App to have my mirrors fold in when locking. It worked flawlessly. There were other things I was planning on trying, but now that I'm reading this, it seems a little scary.

I have a 2015 X5 x35d.

No errors, no alarms, no issues. Maybe I lucked out? How many others have had issues with it?
 

·
Bayerische Motoren Werke
Joined
·
1,002 Posts
Used it on our new 2017 X5 in the spring of last year for a variety of changes with no issues at all. Used Vgate Wifi iCar2 OBDII from Amazon.

Havent used it since though.
 

·
Registered
Joined
·
2 Posts
I bought the Veepeak OBDCheck BLE OBD2 Bluetooth Scanner from Amazon (https://amzn.to/2NoAaTz), and used it with the Bimmercode App to have my mirrors fold in when locking. It worked flawlessly. There were other things I was planning on trying, but now that I'm reading this, it seems a little scary.

I have a 2015 X5 x35d.

No errors, no alarms, no issues. Maybe I lucked out? How many others have had issues with it?
I have coded my 2014 328i using the Veepeak also without issues.
 

·
Registered
Joined
·
31 Posts
BimmerCode now supports a totally new, more expensive and better adapter... and it is optimized to use that one. Forget about the vGate 2
 

·
Registered
Joined
·
28 Posts
I used a Vgate bluetooth adapter last night. It worked but lost connection a few times.

Anyone know if the Sport+ mode is available in the F15? It doesn't appear as an option.
 

·
Registered
Joined
·
23 Posts
I had my 2011 BMW 550i running while I was coding the HeadUnit Module with Bimmercode. I chose to close i-Drive when vehicle shuts down. When I pressed 'Code' it started coding, finished coding, then the engine shut down and the Headunit went blank. Once I restarted the vehicle I tried to restore the Headunit module since the i-Drive display did not come on. Restore failed. When I tried it again, the restore failed again. I shut the vehicle off, locked it, the waited a few minutes before starting it again. When I did and opened Bimmercode the Headunit ECU did not show up. WTF?!! :mad::mad: Now I have No Display at all, Radio, Navigation, Nothing!!! I just bought this vehicle less than a week ago from a private seller. BMW JUST replaced the engine it for them and installed a brand new front suspension system. I got it for one Helluva a deal. This would be my 6th BMW. Any help would be GREATLY appreciated.

10 minutes after writing this, I went back to the vehicle, started it, and noticed the display came up (what a relief :) However, it wasn't the original display. I'm thinking the Headunit ECU was rebuilding itself. I can see it in Bimmercode and I tried to do a 'Restore'. The restore failed. I'm okay with that for now because I'm going to give it some more time to see if it IS rebuilding itself. Will update later as things progress. They ARE progressing so far :)

Third update within the hour: I'm done for now with this Bimmercode App. Now I notice my Climate ECU selection is gone as well. I'm just going to let the car sit over the weekend and tackle it again Monday. I have a road trip-not with this vehicle, Thank GOD. I'll be monitoring this post for updates and assistance. Thanks.

The video that caused all the problems....when I "turned off" i-drive :cry:

https://www.youtube.com/watch?v=MSA2tJUtWqE&t=396s

Current:
2011 550ix Premium Package, Sport Package
2005 530i

Gone but not forgotten:
1998 528i
1993 325i
1985 320i
1978 1802
 

Attachments

·
Constantly Learning
Joined
·
2,020 Posts
Good info here. Nice reminder to be cautious - if I ever messed something up on my wife's car I'd never live down. ;-)

FWIW, the Bimmercode site now says don't buy Vgate. I purchased the Veepeak and it seems to connect easily, haven't coded anything yet.
 

·
Registered
Joined
·
8 Posts
Good info here. Nice reminder to be cautious - if I ever messed something up on my wife's car I'd never live down. ;-)

FWIW, the Bimmercode site now says don't buy Vgate. I purchased the Veepeak and it seems to connect easily, haven't coded anything yet.
I, too, got mine today. I'm reading as much as I can and watching as many vids I can before I jump in.
It's kinda scary... :eek:

Cover me....I'm going in!

Good luck with your coding. Let me know how it goes! :)
 

·
Registered
Joined
·
8 Posts
:thumbup: :thumbup: :thumbup:

Well that was fun!!!

I sat in the car for a long time coding things. All worked great.
Yes....it was scary with each bing, and blank screen. In the end, all is good!

I may or may not be interested in finding out how to read the expert mode side of things now! :dunno::D
 
1 - 20 of 21 Posts
Top