BimmerFest BMW Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently replaced the final stage resistor in my 2000 323i. After replacement, the blower worked fine..at first. Now the blower only works 3 out of every 5 times I get in the car, and I have this loud humming noise coming from what I assume is the blower. I'm just a DIY'er and my mechanic skills are limited to what I read on forums and see on Youtube.

Any suggestions on what this could be? All help is greatly appreciated!
Thank you!
 

· Registered
Joined
·
4,287 Posts
This^.. Or could be that the FSR wasn't actually bad and it was really your motor crapping out on you?

So it's definitely humming and not scraping or rubbing?

EDIT":
Look in the HVAC section of the wiki for cricket/screeching in vents. That issue is the fan wearing out or getting out of balance, but it tells you how to get to the fan which I think is just take out the cabin filter assembly under the hood, and a panel or two behind it on the firewall where the fan is. Then you can see what the fan is doing. Also, I think a diagnostic step is to put 12v directly to the fan motor plug to see if it turns ok without the FSR in the loop, to see if the FSR is bad or the fan.

Careful with the fan blade/cage. I think one of the flaps/doors in the vent right next to it can be taken off to allow easy removal.

e46 wiki: http://www.bimmerfest.com/forums/showthread.php?p=8014505#post8014505
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Also, I noticed when I got out of my car the other day, I had some smoke coming from the vent that comes out of the hood by the windshield. I watched a youtube vid on how to change the blower motor and the smoke was coming from that area. It was definitely a humming noise that got faster the higher the fan speed. I'm pretty sure its the motor
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top