Bimmerfest BMW banner

1 - 7 of 7 Posts

·
It's all about me!
Joined
·
1,519 Posts
Discussion Starter #1
Hoping to get some assistance on a bluetooth question. I'm currently troubleshooting a bluetooth issue with my 2009 BMW X3. I can hear people on my end but the person on the other end can't hear anything at all.

I wanted to check both the microphone and the antenna....and I found the microphone right where it should be, but in looking in the back compartment, I do not see a bluetooth antenna anywhere. I also don't see any unused connections where perhaps it is missing from.

I have read in multiple places it should be in the back by the TCU unit, but mine isn't......wondering if any of these are placed under the center console in the front? Would appreciate any feedback anyone has on the antennas location in a 2009.

TIA
 

·
Nuclear engineer
02/2012 X5 35d M57Y CPO 99K miles NOKIAN WR G3 12K miles
Joined
·
17,494 Posts

·
It's all about me!
Joined
·
1,519 Posts
Discussion Starter #3

·
Registered
Joined
·
1,543 Posts
Lol I have the exact same problem on flipped. I can’t hear them but they can hear me - basically no sound is produced through car speakers. This is a hit or miss when it works and not.

How is your phone connecting to the TCU without a Bluetooth antenna? Typically the antenna is fastened to the left rear cubby area where the TCU is but above where the wheel well is..


Sent from my iPhone using Bimmerfest
 

·
It's all about me!
Joined
·
1,519 Posts
Discussion Starter #5
Lol I have the exact same problem on flipped. I can’t hear them but they can hear me - basically no sound is produced through car speakers. This is a hit or miss when it works and not.

How is your phone connecting to the TCU without a Bluetooth antenna? Typically the antenna is fastened to the left rear cubby area where the TCU is but above where the wheel well is..


Sent from my iPhone using Bimmerfest
Good question......I'm assuming the antenna is fine, but am literally checking all aspects of the system to see if I can isolate the problem. You would think it was the mic in my case, but it seems fine, so just trying to rule things out....

All my research showed the antenna in the cubby compartment above the TCU, but it is not there. The other possibility was the center console but didn't see anything there either. Doug's post about the C pillar makes a bit of sense since I see no empty connections in the back cubby, so I'm going to try that next.

My phone sees the signal and connects....when I dial or receive a call it comes up on my radio with the number being called.....but just no audio coming from my end.

Frustrating....
 

·
Registered
Joined
·
1,543 Posts
Good question......I'm assuming the antenna is fine, but am literally checking all aspects of the system to see if I can isolate the problem. You would think it was the mic in my case, but it seems fine, so just trying to rule things out....

All my research showed the antenna in the cubby compartment above the TCU, but it is not there. The other possibility was the center console but didn't see anything there either. Doug's post about the C pillar makes a bit of sense since I see no empty connections in the back cubby, so I'm going to try that next.

My phone sees the signal and connects....when I dial or receive a call it comes up on my radio with the number being called.....but just no audio coming from my end.

Frustrating....
Your bluetooth antenna plugs into the TCU. Look at your TCU module in the rear, it should have a few plugs on it. One big black one, a white one (mic) and a blue one (bluetooth antenna) check where the blue connector wire goes.

Your antenna is most likely up where the screw is top right corner behind the carpeting likely tucked away a bit deeper by the well.

 

·
It's all about me!
Joined
·
1,519 Posts
Discussion Starter #7
Your bluetooth antenna plugs into the TCU. Look at your TCU module in the rear, it should have a few plugs on it. One big black one, a white one (mic) and a blue one (bluetooth antenna) check where the blue connector wire goes.

Your antenna is most likely up where the screw is top right corner behind the carpeting likely tucked away a bit deeper by the well.

Thanks...I looked there once but didn't see it. I'll trace down the blue wire and see if track it down. I'll let you know what I find.....
 
1 - 7 of 7 Posts
Top