BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone, I have owned a 07 335i w/ 115K miles for 3 years and recently started hearing a noise when acceleration and transmission possibly slipping. In order to avoid the feeling of slipping, I accelerate slowly. Checked fluid level, seems fine. Questions: Do I need to replace the transmission? Could it be something else? Any help or ideas on how to tackle problem would be appreciated. I will not take it to the dealer. Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I have not done anything to the transmission. What is this lifetime fluid that BMW talks about, from reading about this problem, I have concluded that the tranny needs to be serviced every 50,000 miles, too late for that now. Problem started, one day I turned the motor on and put it on reverse and I felt this strange hesitation as if the car is running out of fuel and 3-5 seconds later is fine. There are no check engine warnings, nothing, just the sound and the feeling of slippage. The noise sounds like an electric motor when you accelerate and you feel that the transmission does not engage properly unless acceleration is very slow and gradual. I am thinking about changing filter, fluid and fluid pump seal and hope for best. If it does not work, will bring to shop and prey!:cry:
 

·
Kevin Goto
Joined
·
41 Posts
the 3 tube seals on top of the valve body also, they will allow fluid past also.
 

·
Registered
Joined
·
3 Posts
Thanks. I told bmw and they basically told me, they are instructed to NEVER ATTEMPT REPAIRS ON THE TRANSMISSION. Just replace. Totall bull! They wanted$9,000, bmw said only courtesy would be a loaner and oil change***x1f626;
 
1 - 6 of 6 Posts
Top