BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey there everybody,

I have a bmw 640d convertible from 2012 rear wheel drive f12/f13.

Today I was going up the hill and transmission went into a kind of limp mode, but without any warning light then after 5 seconds while I was trying to find a place to park and see what's going on, the warning light of the steering wheel turned on and I could not turn without using a lot of hand power to turn a bit. It lost all the steering power.

I restarted the car after I drove 5 meters further with it, and the transmission worked perfect, but the steering wheel warning light was still there and so hard to turn with it.

Is it a fuse? because it never done any pre-sound to think that something is broken, or any oil leak.Is it something with the battery? the battery is on low voltage and need to be changed.

I have searched all over the internet for the electric/fusebox diagram, but there is no luck.

I hope you can help me guys.

I have attached pictures of the warning light, and my car.

Thanks in advance.

Kind regards
Alexander Jensen


WhatsApp Image 2021-05-11 at 18.45.04.jpeg
WhatsApp Image 2021-05-11 at 18.45.06.jpeg





WhatsApp Image 2021-05-11 at 18.45.05.jpeg
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
UPDATE: So today I spent 4 hours with local mechanic to see if I can fix the car for a cheaper price.
Changed the VARTA battery, because they said that it was nearly 7 years old, and could be the main problem. It cost 330 euro ( 400 dollar ). They changed it and deleted the error but it came back again after restarting the car.
After that they were pretty confused and then they took the battery off for 10 minutes to restart the system ( that did not help at all ).
They mechanic could see that there is another battery ( auxiliary battery ), and it was not charging.
They spent around 30 minutes trying to find it, then they were out of time and they will continue working on it Monday.

My question now is, where is the auxiliary battery on the 640d?

I will keep this thread updated so I hope it helps anyone out there whose having the same problem.
 

·
Michael
Joined
·
2,518 Posts
Firstly you need to ensure the new Battery is registered to the car, this is important, you cannot just change the battery on these cars. As for the aux battery it is normally in the boot, but I have seen it positioned at the front below the plastic scuttle at the back of the engine. For the aux battery to fail would almost certainly show up before failure so it could be a fuse. There are diagrams with the fuse locations on the site, just have to do a search, or look up the TIS manual or the WDS for the car (wiring diagrams)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top