BimmerFest BMW Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
730 LD 2005 model

My car is Parked at home(Pakistan) and I am here in UK.
My son strat car after every three days.
Yesterday car was start and he shifted the Gear from P to D.its work but latter on transmission faild to go in P only in N and D.
Screen and Metrer speaks as below:
1- Driver restraint system fault.
2- Safty system
3- PDC failuer
4- Gear Box position in N
5- Transmission position P fault
Navigation screen speaks as below:
1- Transmission faulty!
Transmission position P poss.
not avaiabale.Operate parking brake when stationary.Have checked by the nearest BMW service.MM1368
2- Tansmission faulty!
Transmission position P poss

Could you please advice me why this happend and what are the action required before i go to service I wana know this as well.
 

Attachments

·
My ride is my glide
Joined
·
1,248 Posts
I have come across this problem before and the fault was the ZGM, the Gateway module. The gear selector on the Steering column goes through the SZL to the ZGM. Hope this helps you.
Merry Xmas
Ace
 

·
My ride is my glide
Joined
·
1,248 Posts
All the faults you described are from all the modules that pass through the gateway module, the ZGM.

1- Driver restraint system fault.
2- Safety system
3- PDC failure
4- Gear Box position in N
5- Transmission position P fault

All the modules have not gone faulty....it is the failure of the gateway module that creates the illusion that everything has failed.

the following modules, SZL, SFZ, SASL, SASR, STVL, STVR, SSBA, SSBF, SBSL, SBSR, SSH, SIM are your Safety modules and Safety Information Management Modules, and they all go through the ZGM, the gateway module.

Also note that your gear selector lever beside the steering wheel connects and passes through the SZL (noted first in list above) which then goes to the ZGM (the gateway module).

This is why you are getting Safety System faults, Driver restarint faults, PDC, Gear Postion faults etc....

How did they fix this fault???...

They replaced the ZGM module.
 

·
My ride is my glide
Joined
·
1,248 Posts
Here is the visual diagram of the Bus Network I am refering to....
the byteflight network is the safety network, gearbox control where the SZL is and they all go through the ZGM (the gateway module)......
 

·
My ride is my glide
Joined
·
1,248 Posts
You would have to go to a dealer to have this fixed and re-coded to your car, unless you know how to replace it and code it yourself.
 

·
Registered
Joined
·
1,905 Posts
Thanks dear.What you advice first to get computer or directly I have to purchase this part and get it replaced.
I would not jump right away to the ZGM being the cause of issues. These modules are very sensitive to voltage fluctuations ...and cannappear to fail with low voltage. I would troubleshoot in the following man we

1. Have the battery and alternator checked. Give the battery a good charge and see if the problems go away.

2. If problem persists after a full battery charge then have a look at the integrated power supply module because it controls the voltage going to each module.

3. Look into ACE's suggestion with the ZGM possibly being bad.
 

·
Registered
Joined
·
444 Posts
I would not jump right away to the ZGM being the cause of issues. These modules are very sensitive to voltage fluctuations ...and cannappear to fail with low voltage. I would troubleshoot in the following man we

1. Have the battery and alternator checked. Give the battery a good charge and see if the problems go away.

2. If problem persists after a full battery charge then have a look at the integrated power supply module because it controls the voltage going to each module.

3. Look into ACE's suggestion with the ZGM possibly being bad.
Need a part number for that module please.
 

·
My ride is my glide
Joined
·
1,248 Posts
Just a follow up.... I had all these exact faults in my car and they replaced the battery three times, put a new alternator in, replaced my SZL three times.... all to no avail.... then they replaced the ZGM and all the faults disappeared.
 

·
Registered
Joined
·
5 Posts
Hello,
I have an 2010 bmw 730ld. When ever i take it out some where a fault arises that charge the battery even though i got a new battery imported from dubai day before yesterday, today i brought it back home from my other house and as i came close to my house the fault arised, it worked perfect yesterday when the battery was new. This happend before and that time my cars gear was stucked in D or N. Everhthings fine in the car but whenever i take it for a drive the fault arises. Please help. Thank you.
 
1 - 12 of 12 Posts
Top