BimmerFest BMW Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
My 2002 BMW 330ci is throwing 8 codes. Any suggestions to fix them. I just replaced the spark plugs and coils.
Here are the codes:

123 thermostat heater, KFk Ground or open circuit

242 burning fail cylinder 5 Misfire carb_b1

240 burning fail cylinder 3

241 burning fail cylinder 4

203 lambda regulating limit bank2 mixture limit rich

202 lambda regulating limit bank1

227 lambda contol tolerance bank1 deviation rich

228 lambda contol tolerance bank2 deviation rich

Any help would be greatly appreciated
 

·
ROLL TIDE!
Joined
·
23,977 Posts
Looks like maybe you need 02 sensors. I'd pull them for a visual inspection or get a code reader that reads real time data from them. What brand spark plugs did you use?
 

·
Registered
Joined
·
68 Posts
Discussion Starter #4
I'm not sure how old the the fuel pump and filter are. I used INPA to read the codes. For the spark plugs I used NGK.
 

·
ROLL TIDE!
Joined
·
23,977 Posts
I'm not sure how old the the fuel pump and filter are. I used INPA to read the codes. For the spark plugs I used NGK.
Hopefully they were 4 pronged NGKs. I've seen more than any few E46s run like crap on single electrode plugs.

In my mind if the fuel pump and filter were at fault, the codes wouldn't be rich, they would be lean. Rent a fuel pressure gauge and see what your pressure is at the rail. Easy and quick to do.
 

·
ROLL TIDE!
Joined
·
23,977 Posts
I'd go with smolck and use your INPA to read live data for your o2 sensors.
If you do need 02 sensors here's a trick to get them cheap, buy online at advance auto parts and select "in store pick up" and use code TRT30 at check out. You'll get 30% off. Order each separately to max the discounts.

One other thought, if youve disconnected the sensors for any reason while doing spark plugs or other maintenance, did you maybe plug them in backwards? I've done this, the car doesn't like that at all. :eek:
 

·
Registered
Joined
·
68 Posts
Discussion Starter #10
The car is no longer misfiring, I am buying new o2 sensors today and trying that.

The only other thing I'm confused on is the lambda codes
 

·
ROLL TIDE!
Joined
·
23,977 Posts
The car is no longer misfiring, I am buying new o2 sensors today and trying that.

The only other thing I'm confused on is the lambda codes
The Lambda codes are the o2 sensor codes, I thought you knew that. Should clear up the issue.
 

·
Registered
Joined
·
117 Posts
It seems to me that if both banks are throwing lambda codes that there is something upstream causing the running rich issue, unless by some fluke both O2 sensors have failed. Caveat: I am new to BMW, but have Volvo, Mazda, and VW experience.
 

·
Registered
Joined
·
5,550 Posts
Could be MAF sensor issue too.

And the thermostat heater circuit is broken but that's irrelevant for the rest.
 
1 - 15 of 15 Posts
Top