BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

Not sure where to start my BMW - E60 - 2004/08 520i Saloon, but for some reason my CCC started rebooting constantly.
First step that I did a hard reset DVD/CD/Power button for 30 secs. Nothing happened it was still rebooting in the same sequence.
Was driving car one day CCC booted fully but then radio sound lowered down suddenly and rebooting started all over again.
I disconnected battery and left it overnight. Came in in the morning car worked like a new, sounds, DVD, Navigation all worked well, I drove car to work for 1.30 hours and parked.
Came back within 3 hours, started car the same all over again, rebooting nothing happens again no sound, no radio nothing.
I just ha d bad feeling that my CCC is gone or some reason it's happening as when I disconnect battery for 2-3 hours all works fine till next drive. I can't disconnect battery every day just in order to make my car working. Any tips?
 

·
Registered
Joined
·
825 Posts
Your CCC is on its way out. Happened to me couple years ago. Options, buy used unit, have it programmed and continue on or, as I did, have a new mother board installed and reprogram. Cost is about the same either way.

Evently they will all die.

Read through, So you just bought a e60, sticky at top of page. A segment on this problem.

Good luck.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks, Jtbgonesailing.

I thought it might be my battarie is too low and that's why it's causing reboots. As in below I mentioned that sound just lowered down and screen was going off slowly, like not enough voltage, maybe alternator gone and voltage in battery is not where it needs to be.

Any links in ebay/amazon for used CCC unit?
 
1 - 4 of 4 Posts
Top