Bimmerfest BMW banner

1 - 5 of 5 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I have a 2006 BMW 330i E90 with 154000 miles. A few weeks ago the engine started to stumble and loose power around 3000 rpm. Has been slow to start for about a year now (slow cranking of engine by starter) but once warmed up it would start instantly if going to the store, etc. Then a few days ago, outside the hardware store, I went to start in and nothing. No cranking or even ticking from the starter solenoid. Figured the starter went out but confirmed with ISTA. Went through the Terminal 50 test and it all looked good. Recommended action was to replace the starter. Got a new Bosch starter and replaced it. Still no start or crank. I tested all the terminals, battery, positive connections under hood, with my DMM. All had 11.89 v.

Brand new battery was the first thing I did before even checking with ista. Bmw battery from 2009, had liquid acid coming out of positive terminal.

Any ideas from you BMW Gods?

Thanks!,
Josh
 

·
Registered
Joined
·
5,991 Posts
After the battery and starter motor the next most likely thing
statistically is the ground strap between the motor and chassis.
The ground strap going bad is much more likely in parts of the country
that salt the roads for the snow season.

You can do a bypass test by hooking one side of a jumper cable between
the motor and chassis.

https://www.youtube.com/watch?v=BZRzlRSY-tU

https://blog.fcpeuro.com/bmw-ground-strap-theory-replacement

If you have a N51 Engine the fuel lines in the gas tank are prone to self dissconnect
the motor would still turn over though.

11.89 is not healthy.
try fully charging the batter. That means a long slow charge.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #5
I am not sure where that is? Would that cause immobilization? It is not even attempting to start. ISTA only says There is a issue at Terminal 50E and 50L in CAS. I can***8217;t find any information online about these terminals. Any ideas? Thanks.
 
1 - 5 of 5 Posts
Top