BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Well started my weekend project of replacing the front brake pads and rotors. I ordered the parts from Bavauto.com. Ordering the rotors there are two sizes that they brake up by build dates of my 540. Production til 2/2000 and then from 3\2000. My 540 states it was produced in 3\2000 so that was the set I ordered. After taking all parts off and puting the new rotor on I started to re-install the caliper mounting bracket. After screwing the bolts in all the way i noticed that it is holding the rotor/disk from turning. The disk seems to be too thick/wrong size. I was just wondering if this is normal for a new rotor or if they did indeed ship me the wrong rotor? I checked part numbers and they did ship the correct one from 3\2000 but it appears their system may be wrong, and if so must be affecting more people then just me. Any help or tips to get this rotor working or if this is normal?


Thanks all!!
 

·
PLN540
Joined
·
69 Posts
I hope not, I also ordered a set from them & plan to put them in this week. Did you compress the inside brake pad back into the caliper?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
I hope not, I also ordered a set from them & plan to put them in this week. Did you compress the inside brake pad back into the caliper?
It's actually the part that the caliper attaches to... It may fit if I add another washer to the bolt but not sure if thats real safe...
 
1 - 4 of 4 Posts
Top