Bimmerfest BMW banner

1 - 20 of 26 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
My car been misfiring and running like crap I plugged in a scanner I borrowed of some1 and got code 0300e misfire sum error
0305
0302
0308
So 3 cylinders misfiring but also intermittently getting 0021 and 0022 codes so after looking into the meaning of these discovered the timing on bank 2 was over retarted and saw a post by jimlev saying pull the valve cover pin the crank and unlock the sensor wheel to advance it a few degrees and sure enough after removing valve cover with crank pinned at tdc found bank 2 sensor wheel to be out almost 180% but I wouldn’t have thought the car would even start with the cam trigger wheel being so far out I’m hopeing this is the anser to my problem the car hasn’t been running right for months luckily I’ve just kept it in the garage the whole time not needing to drive it but has anyone else found this to be the anser to there problems


Sent from my iPhone using Bimmerfest mobile app
 

·
Registered
Joined
·
7,403 Posts
In my case it ended up being the vanos was bad. The shop saw the trigger wheel was slightly off and adjusted, but no joy. They said retiming might correct it, but might as well replace the vanos at the same time, even though it had been rebuilt about 20 or 25k ago.
 

·
Wingnut
Joined
·
3,703 Posts
My car been misfiring and running like crap I plugged in a scanner I borrowed of some1 and got code 0300e misfire sum error
0305
0302
0308
So 3 cylinders misfiring but also intermittently getting 0021 and 0022 codes so after looking into the meaning of these discovered the timing on bank 2 was over retarted and saw a post by jimlev saying pull the valve cover pin the crank and unlock the sensor wheel to advance it a few degrees and sure enough after removing valve cover with crank pinned at tdc found bank 2 sensor wheel to be out almost 180% but I wouldn’t have thought the car would even start with the cam trigger wheel being so far out I’m hopeing this is the anser to my problem the car hasn’t been running right for months luckily I’ve just kept it in the garage the whole time not needing to drive it but has anyone else found this to be the anser to there problems


Sent from my iPhone using Bimmerfest mobile app
not deeply familiar with the v8 model, but i believe that when pinning the crank, you can be at TDC or 180 out from it.
 

·
Registered
Joined
·
5,034 Posts
So 3 cylinders misfiring but also intermittently getting 0021 and 0022 codes so after looking into the meaning of these discovered the timing on bank 2 was over retarted and saw a post by jimlev saying pull the valve cover pin the crank and unlock the sensor wheel to advance it a few degrees and sure enough after removing valve cover with crank pinned at tdc found bank 2 sensor wheel to be out almost 180% but I wouldn’t have thought the car would even start with the cam trigger wheel being so far out
So have you looked at cylinder 3, oil in plug well, or swapped the coil and plug with another cylinder?

As far as the trigger wheel being 180º out are you sure the crank was pinned with the #1 cylinder on the compression stroke and not on the exhaust stroke?
I'd check the above before you do anything with the trigger wheel.
How may miles on the engine? It's possible your guides are starting to fail.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Really appreciate all your feed back Guys It’s so good to actually be able to talk about this stuff with not only 1 but a few who actually care or are interested in what your saying and Jim your a legend mate can’t believe I’m even talking to you but yes I checked the plugs which where only installed about 6 months ago and they are a little blackened but by mostly soot from the missfiring I think not really oily plus after plugs I have put all new Bosch coil paks as they where the original ones from 1998 I though was probably due to change them anyhow and I’ve tried swapping plugs and coils to see if there was any change but nothing same 3 cylinders I’ve replace both cam sensors and solonoids as they where all original parts and probably well over due I also have change the timing guides about a year ago and the car ran beautifully for about 6 months then the dramas started and I followed your instruction with the timing to a tea Jim it was actually after I had to pull everything apart again because of a cracked alternator housing which my dickhead housemate backed into when I did the timing job and had parts sitting around the garage and who failed to tell me untill I notice the leak. Comeing from a hairline crack in it but anyway and mind you when I noticed the guides had failed I took it to a local mechanic who said to me just call tip some 1 will give u 500 bucks it’s good for rubbish he said or he sai it would cost me about $8000 and he couldn’t promise anything g there would still be problems so I was kinda wrapped with my outcome it cost me 600 in parts and about 3 days to fix it and I just don’t want to ever go to anouther mechanic again no offence to any1 but there all thrives here if there’s a mechanic in buisness it’s because he’s robbing every1 blind


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Also you got me thinking about wether if on exhaust or compression stroke I mean the numbers on back of cams where all pointed up the OT marks lined up and the pin went in through the hole in bell housing would all those points of reference line up on both exhaust and compression??


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
So just to up date I pulled bank 2 valve cover of spun the wheel around to where it should be and she fired straight up and ran real good but sure enough light started flashing and all the same codes 0021
0022 camshaft control
And still missfiring on 8,5,3
It’s driving me mad I’m at the point where I’m about to throw the towel in and give this friging nightmare to some1 else or actually throw it to the scrap no 1 deserves to go through this much dissapointment


Sent from my iPhone using Bimmerfest
 

·
Under the lift arms
Joined
·
12,946 Posts
I wouldn't have touched the trigger wheel.. It doesn't make sense that now all of a sudden you have a problem with that (that would have been a problem you would have had immediately after doing a timing job)

What i would have done is looked at the live data for the advance Degree (to figure out what the engine is trying to compensate)

Po30# (Cylinder # Misfire Detected) *does not include fuel cut off, Which tells me right off the bat that engine doesn't know where It is in its stroke (or its lost its indication)

I would have looked at the timing advance, then went right for the cam sensors or crank sensor..

The computer is having a hard time locating the position of the crank about half way thru the cycle... Look at my signature, The firing order for the v8


Live data, if you can map the live data to see if the input lose is happening on the intake (cam) or exhaust (crank)
 

·
Under the lift arms
Joined
·
12,946 Posts
*i had to post to see the firing order lol

You can see its in the first closer to the start of the order, and now the rear..


Id suspect a cam sensor on the drivers side *total guess... with out info
 

·
Registered
Joined
·
20 Posts
Discussion Starter #11
I’ve replaced both cams and the crank sensor besides car wouldn’t even start if it was the crank and so I decided pull bank 1 valve cover of and the hole on trigger when crank at tdc was about 6 or 7 mm of so I advanced it to where it should be put it back together fired up and now I’m only getting the 0022 camshaft control code there was even no misfires for a few restarts however there back again but no 0021 code which is something


Sent from my iPhone using Bimmerfest mobile app
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
Your right though it’s missing every second cylinder on the firing order sometimes there’s 4 cylinder and sure enough it’s num 2 wow why didn’t I ever notice that


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
5,034 Posts
You are using the cam lock blocks, right? What timing tools are you using?
Are you sure that any of the tabs on the trigger wheel aren't bent?
Initially you said the trigger wheel was 180º off, how did that happen?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #14
I am using the cam blocks the kit I used was exactly the same as the 1 you use in your video however when I pulled bank 2 valve cover of the outher day I didn’t use them but it got me thinking about wether I was on compression or exhaust stroke because it’s got me how it could be 180 degrees of but the nut was tight so is everything else and can you tell me Jim is it possible for all the points of reference to line up on both compression and exaust stroke


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #15
The tabs are all good after I adjusted bank 1 yesterday the misfires stoped and the 0021 code is gone completley however missing again now and the 0022 code is still there


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
5,034 Posts
I think you might be better off to retime the engine. Watch my video again, pause it after you watch each part and then do that part.
Make sure the cam lock blocks stay down on the back of the heads, they have a tendency to want to move up a few degrees which can contribute to getting a code.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #17
I’m about to get into it now and I’ll update when finished I tell you what I can pull this motor apart with my eyes closed now which I geuss doesn’t really acount for much when you put it back together and it’s not right but here we go again what’s actually quite annoying is the very first time I did this job I didn’t have any special tools nothing and the car fired up and ran beautifully it must have just been an absolute fluke but you wouldn’t think after using them you would have so much trouble


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #18
It’s got me stumped so got both covers of wound it around to tdc and everything’s lined up the front lobes the numbers at back the dots in the middle and bank 1 trigger is still where I put it yesterday but bank 2 is 180 out again any ways I’ll finish put everything back together and see what happends


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #19
So all done now now camshaft codes but sure enough misfires on 8,5,3 then I turn car of and on again and there gone but then next time there there again what in the hell could it be could it be the egr valve blocked or the oil control valve do u think


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
20 Posts
Discussion Starter #20
Would it throw the timing of if I removed the helical gear from inside the vanos I did that befor this problem started just to look at it then I’m sure I read somewhere that there balanced and shouldn’t be removed


Sent from my iPhone using Bimmerfest
 
1 - 20 of 26 Posts
Top