BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
277 Posts
Discussion Starter · #1 ·
Alright...
My car has the SEL light come on and off intermittently. When the light appears, the low range rpm's bogg the engine down, and it sounds like its under a lot more "load" than needed. She stalls every now and then as well, even though I've been driving a manual for almost 10 years. She has 60k on the odo.
I've narrowed my search down, and I want to change the Camshaft Position Sensor(s). After extensive research (Google), I found a DIY for the Intake, although I can't find one for the Exhaust sensor.
Can someone point me in the right direction? :p
I hope its not the Coils... if it were the coils, would the SEL light stay on all the time? Would I even be able to get the car aove a certain speed? As mentioned, the car starts hard, and "boggs" when trying to push through the gears...
Let me know if more information may be needed, or if I'm going down the wrong road. I stopped at Autozone to have my codes read, and they couldn't pull any...:dunno:
 

·
Registered
Joined
·
277 Posts
Discussion Starter · #3 ·
Thanks for the heads up, I thought that with 60,000 miles, this may be normal MNT to chage out the parts. I will try to locate the exact Fault Codes, and return to this thread.
Thanks for your help.
 

·
Banned
Joined
·
310 Posts
Blinky330XI said:
Thanks for the heads up, I thought that with 60,000 miles, this may be normal MNT to chage out the parts. I will try to locate the exact Fault Codes, and return to this thread.
Thanks for your help.
The camshaft position sensors can go out at any mileage (before and after factory warranty). It is a common problem though.
 
1 - 4 of 4 Posts
Top