BimmerFest BMW Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hey, so I recently had an odd key problem that I fixed by manually programming and encoding my CAS module in ISTA. Now the odometer displays kilometers, and my HVAC is in Celsius. How do I fix this?

My car is a 2012 528xi that I bought as a repo and restored. Since a key was missing, I went into ISTA to disable the missing key. It detects the current key to ensure you can't block out your only key! Anyway the process of blocking the key failed saying it couldn't detect the current key in the car. After that point my comfort access and remote didn't work. I could only open my doors with the key blade, and had to hold my key to the column to allow starting. Various resets, battery replacements, and VO coding were unsuccessful at fixing the issue.
Since my car was already running F010-18-11-520, E-sys didn't offer a programming option. I loaded up ISTA 4.15.16 and selected manual programming and encoding of the CAS module. Now my key is working perfectly, but the car is Metric. I have backups of my FA, SVT, etc from before all this.

I've attached a copy of the following files, just change extensions.
Ops Report DW06456.pdf -operations report from ISTA
DW06456.xml -backup SVT running current i-step, but before FDL coding
DW06456_N.xml -new SVT from my now metric car

Thanks in advance!
 

Attachments

·
Registered
Joined
·
38 Posts
Discussion Starter #2
Fixed!
I just needed to go into CIC settings and change units there. It wasn't a coding or programming issue after all. Something got strange with the ISTA step of backing up and restoring personalization settings from the CIC. Somehow I ended up with radio station presets from someone else's car.
 
1 - 2 of 2 Posts
Top