BimmerFest BMW Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
She starts up fine, but as soon as I give her gas she bogs big time and is completely undriveable (got halfway down the street on my way to work when she bogged and died, limped her home about 200ft.) She's not throwing any codes, hooked up a scan tool and it came back all clear so no help there. If it were the maf, cps, o2 sensors or cats I think I'd get a code of some kind. Could be fuel related? New filter perhaps? :dunno:
 

·
Registered
Joined
·
1,564 Posts
Try unplugging the MAF.


Bill
 

·
1 Red 540
Joined
·
359 Posts
Uhh i just fixed this prob, its your pre cat o2 sensors, i got them brand new oem from BMA in Cali (818-240-1223) for 68 each and after i installed them and drove the car for 15 min 100% solved the problem.

I was getting no visible warning from the cockpit but when i scanned the code it came up. Those sensors tell the car how much to adjust fuel and other elements so when they are broken you get bogging or stalling (i was getting back fire too). It would be better above 3k but when i would coast to a light the car would cut off and not want to go until i hit 3k or so. I actually felt the car was faster after i replaced those, i also replaced the maf cause that gave me an engine light but that wasnt related to this problem.

Sorry for the longwinded response hope this helps though Just call Yevs (eve) at BMA tell him steve (me) or dalton sent ya. Kindly guestimate while they are checking that the part was around 68 dollars or so. and they will ship them out same day. 818-240-1223. Took me all of 15 minutes which included jacking the carup , replacing 2 (540), till taking it down. Again sorry for the long response hope that solves it.

Steve
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #6 ·
She won't rev at all. As soon as I hit the gas that tach needle goes straight down and just bogs like a tractor. I don't want to damage the car, but I think I'll replace the CPS first, than the pre-cat sensors, than the MAF in that order. I'm kinda tight on money now so I don't want to replace anything I don't have at this very moment.

Thanks for the suggestions guys.
 

·
just havin a heart attack
Joined
·
2,741 Posts
driving with a bad CPS CAN cause the car to eat up your cats, so dont drive it.
 

·
Registered
Joined
·
620 Posts
When you say that the car is not throwing any codes, did you check with a reader or just assume since the CEL is not lit there are not codes?
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #9 ·
I used a peake scan tool that I bought a while ago. It comes back negative. :dunno: I replaced the valve cover gaskets and spark plugs awhile ago but she was purring like a kitten when I buttoned her up so it probably isn't related to that. I know I have to replace some idler pullies and I think the powersteering is start to go, but when I start her up she seems to idle fine and everything looks like it's functioning. But when I touch the gas, she falls on her face.

As far as attempting to drive it, she can't go anywhere, I'd tried moving her from my lawn (moved her out of the way for another car) into the carport but that was my last attempt to drive her.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #10 ·
So I replaced the CPS sensor, problem hasn't gone away. Doesn't idle anymore, won't go over 500rpms, give it gas, falls on her face and dies. No codes through the scan tool. :dunno:

Could it be the fuel pump, powersteering pump, anything like that? As soon as I hit the gas she tanks, and if she even idles it's at extremely low rpms, very lumpy like she's just barely holding on. Sometimes when I start her she sounds beautiful for a few moments, then bogs, then gradually declines into a tractor and then dies.
 

·
Registered
Joined
·
119 Posts
She won't rev at all. As soon as I hit the gas that tach needle goes straight down and just bogs like a tractor. I don't want to damage the car, but I think I'll replace the CPS first, than the pre-cat sensors, than the MAF in that order. I'm kinda tight on money now so I don't want to replace anything I don't have at this very moment.

Thanks for the suggestions guys.
Just had this problem today and suposedly my fuel pump died and control unit is on the way out.

Another $900 out the door:cry: At least they give me nice loaner cars.
 
1 - 11 of 11 Posts
Top