BimmerFest BMW Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
My car when in drive is squeeling liker mad. Sounds like a belt but isnt. It stops if a little gas is pressed. THe car seems to hesitate on take off. Im out of warranty just now. I have 92K miles on her. Please help.
 

·
Registered
Joined
·
3,344 Posts
i had squealing symptoms similar to yours a few months back and then got the low coolant message as well. turned out to be water pump.
 

·
Master Tinkerer
Joined
·
2,218 Posts
+1, likely the bearings on a pulley (water pump included). You should be able to pop the belts off and spin / wiggle each pulley by hand to tell which is noisy / wobbly. Could also be a little liquid on the belt (coolant / power steering fluid / oil).
 
 

·
Registered
Joined
·
66 Posts
Discussion Starter #5
So everyone would suggest I pull the belts off and see if something is wobbly etc?

What about the oil leak? do you think this is part of the problem or a separate issue?

760LI in HELL right now:(

Thanks
 

·
Registered
Joined
·
530 Posts
sounds like the fan belt !?
The fan is electric and not belt driven. I could be a bearing. get an automotive stethoscope and listen to the bearings.
 

·
Master Tinkerer
Joined
·
2,218 Posts
Based on realoem.com's diagrams, the 760 / N73 looks like it still has a pulley-driven water pump and fan.

+1 on Judd's post, get stethoscope and listen or pull belts off and just spin each pulley until you find a loud or wobbly one.

Oil leak? Where does the oil appear to be leaking from? Pictures?
 
 

·
Registered
Joined
·
530 Posts
Ahh, I missed the 760 part.
 
1 - 8 of 8 Posts
Top