BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter · #1 ·
Just went to start the car this morning. Got like 3 clicking noises, dash lights all work, interior fan came on. The headlights did a flickering in time with the clicking noises...all internal lights work....HELP ME!!!! PLEASE......
 

·
The Biggest P0st Whore!!
Joined
·
2,912 Posts
Sounds like your battery does not have enough juice to start the car. Try jump starting or test/change the battery. You can have enough power to run the accesories but not enough to run the starter.
 

·
Registered
Joined
·
333 Posts
Discussion Starter · #4 ·
My radio does not come on and my temp sensor now reads -40. I have a feeling it may just be the battery...It's the cheaper thing to replace, so I will try that first. Thanks!!!
 

·
Registered
Joined
·
467 Posts
Try jump starting and when the car is running, measure the voltage of your battery. If it is less than 13.5 Volts, then you'll have to replace the alternator instead of the battery.

If you don't have a voltmeter, try Test Nro. 9 of your OBC
http://www.ideaphile.com/bmw/540-obc.html
 

·
Registered
Joined
·
333 Posts
Discussion Starter · #6 ·
Replaced the battery with one from AutoZone...Titanium:dunno: Started right up...thanks to everyone for suggesting the battery route first.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top