BimmerFest BMW Forum banner

Clicking noise coming from engine bay of 2012 X5d

2132 4
So I started hearing a clicking noise coming from the engine, usually in the morning when I first start the engine, and mostly right when I put the car in reverse to pull out of the garage. The noise is intermittent and is not proportionate to the engine RPM. It's just random clicking. It lasts for a few seconds and then stops, even if the car is still in reverse. I have not been able to reproduce this problem when the engine is warm. I have also not noticed any problems in the car's performance.

Took the car to the dealership (after work) and of course we could not reproduce the problem. They kept the car for a few days and started it in the morning every day. On a couple of occasions, they DID hear the clicking. However, since it only lasted a few seconds, they could not locate the source. They involved BMW (PUMA I think) to no avail. They decided to give me the car back. I'm supposed to go back if the problem gets worse. BMW is "investigating".

Has anyone had a similar issue? Any ideas what the problem could be? I appreciate any help with this.
1 - 5 of 5 Posts
I have the same thing in my '12 x5d. I notice it only when I'm in the garage and my wife happens to leave before me (like you said, first start of the day). I can't hear it if I happen to be driving.

I've never been too worried about it, as diesels inherently make a lot of clatter and this engine has a ton of history (minus the aftertreatment crap). Could be something as simple as a change in injection timing due to emissions which are the worst during a cold start.

I am a little relieved that I'm not the only one though :)

Jay
Hey Jay,

Thanks for your reply. I had a 2010 X5d for a couple of years and I don't remember it doing this... Of course my current X5d had a problem with the engine from day 1, literally (started a couple of hours after I took possession of the car). It was a faulty pulley that resulted in damage to the belt and power steering fluid hose. The car was at the dealership for 2 weeks for that... So, needless to say I am now paranoid about any unexpected sound coming out of this engine. That's why I took the car to the dealership for the clicking sound. I just wanted to make sure nothing is being damaged slowly but surely. How long have you had your car and did you notice the clicking sound from the get go or did it develop with time? Also, is it getting worse or is it sill the same?
I have the same thing in my '12 x5d. I notice it only when I'm in the garage and my wife happens to leave before me (like you said, first start of the day). I can't hear it if I happen to be driving.

I've never been too worried about it, as diesels inherently make a lot of clatter and this engine has a ton of history (minus the aftertreatment crap). Could be something as simple as a change in injection timing due to emissions which are the worst during a cold start.

I am a little relieved that I'm not the only one though :)

Jay
Its been since day 1, and has not gotten any better/worse. I've got a little over 12k miles on it in 9-10 months, in both sub-freezing and >100 degree temperatures and doesn't seem to change. I hardly think about it now when I hear it.

Please keep the thread updated if you have any findings. Sorry to hear about the belt/pulley issue that's pretty lame.

Jay
OK, well then I'll just live with it and try to ignore it, unless it gets worse or something. Good to know you've put all those miles on your car with no problems... I'll definitely update this thread with any news. Thanks Jay.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top